FIX: A Windows-based application that uses the ENTSSO service may start experiencing logon errors from a remote application after a user changes the Windows password in Host Integration Server 2004 (904771)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

Consider the following scenario. A Microsoft Windows-based application successfully uses the Enterprise Single Sign-On (ENTSSO) service to let a user log on to a remote application by using single sign on (SSO) in Microsoft Host Integration Server 2004. After the user changes the Windows password, the Windows-based application may start experiencing logon errors from the remote application.

An Advanced Program-to-Program Communications (APPC) application or a Common Programming Interface for Communications (CPI-C) application may receive the following return codes:

Primary Return Code = 0003 (AP_ALLOCATION_ERROR)
Secondary Return Code = 080F6051 (AP_SECURITY_NOT_VALID)
An application may receive these return codes after the application issues an APPC ALLOCATE verb to establish a conversation with an IBM mainframe application when this problem occurs. The actual return codes that are returned to the Windows-based application depend on the application that is being used.

CAUSE

The logon errors occur because an invalid password is sent to the remote application.

The ENTSSO service does not examine the return code in a response from a password synchronization adapter before the ENTSSO service updates the SSO credential database. This behavior occurs when the ENTSSO service synchronizes a password change to a remote system, such as an IBM mainframe or an IBM AS/400. If the remote password change fails, the ENTSSO service incorrectly updates the new Windows password in the SSO credential database. The next time that the user starts the Windows-based application that uses SSO to log on to the remote application, the logon request fails. The logon request fails because the password that is stored in the SSO credential database does not match the user's password on the remote system.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version    Size     File name
------------------------------------------------------------
22-Jul-2005  01:08  4.0.124.0   70,144  Infocache.dll
22-Jul-2005  01:08  4.0.124.0   81,920  Ssolookupserver.dll
22-Jul-2005  01:08  4.0.124.0   60,928  Ssomappingserver.dll
22-Jul-2005  01:09  4.0.124.0  115,712  Ssopsserver.dll
16-Jun-2005  22:53              28,188  Ssox4.sql

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix must be applied to any system that is running the ENTSSO service where password synchronization adapters are also installed for use with password synchronization.

After you apply this hotfix, the ENTSSO service does not update the Windows password in the SSO credential database if the ENTSSO service receives a status update from a password synchronization adapter that indicates that the remote password change failed. When the remote password change fails, the ENTSSO service logs the following event:
Event ID: 10737
Source: ENTSSO
Description: Failed to update the external password in the SSO database.
Tracking ID: GUID
Adapter: Password Synchronization Adapter Name
Application Name: *** (Error Code) Error Message from adapter
External Account: External User Account
Error Code: Error Code The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug kbpubtypekc KB904771 kbAudDeveloper