FIX: You receive a "Page cannot be displayed" error message in Internet Explorer 5.01 in the hour before system uptime reaches 49.7 days (904161)



The information in this article applies to:

  • Microsoft Internet Explorer 5.01, when used with:
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional

SYMPTOMS

Consider the following scenario. The system uptime of a Microsoft Windows 2000-based computer approaches 49.7 days. In the hour before the uptime reaches 49.7 days, you try to open a Web site in Microsoft Internet Explorer 5.01. In this scenario, you receive an error message that is similar to the following:
Page cannot be displayed

CAUSE

This problem occurs because Internet Explorer 5.01 does not expect the returned value for the GetTickCount Win32 API call to be less than a stored value that was previously returned by using the GetTickCount Win32 API call.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 Update Rollup that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Windows 2000 installed to apply this hotfix.

Restart information

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

You do not have to create or modify any registry keys to enable any hotfixes that are contained in this package.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------   
   08-Sep-2005  04:17  5.0.3900.7070  451,344  Wininet.dll   

WORKAROUND

To work around this problem, use one of the following methods:

Install Internet Explorer 6 Service Pack 1

To work around this problem, download and install Microsoft Internet Explorer 6 Service Pack 1 (SP1). For more information about how to download and install Internet Explorer 6 SP1, visit the following Microsoft Web site:

Restart the computer

To work around this problem, restart the computer before the computer approaches 49.7 days of uptime.
For more information about the GetTickCount Win32 API function, visit the following Microsoft Developer Network (MSDN) Web site:

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 5.01.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbbug kbQFE kbHotfixServer kbpubtypekc KB904161 kbAudITPRO