You cannot view other workgroup computers on the network on a Windows XP-based computer (903267)



The information in this article applies to:

  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario. You are working on a Microsoft Windows XP-based computer for which the following conditions are true:
  • The computer resides on a network.
  • The computer is a member of a workgroup.
  • Either no firewall is enabled or no firewall is installed on the computer.
  • The computer can ping other computers in the same workgroup. Also, other computers in the same workgroup can ping this computer.
  • NetBIOS over TCP/IP functionality is enabled.
In this scenario, you cannot view other workgroup computers on the network.

CAUSE

This issue may occur if the computer is configured to use p-node mode for name resolution. To determine whether a computer is configured to use p-node mode, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type ipconfig /all, and then press ENTER.
View the Node Type section at the start of the output. If the value that appears on the screen is Peer-Peer, the computer is running in p-node mode.

In p-node mode, the computer uses only point-to-point name queries to a Windows Internet Name Service (WINS) server. However, the WINS server is not available for NetBIOS name resolution on a peer-to-peer network.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBt\Parameters

  3. In the right pane of Registry Editor, delete the following values if they are present:
    • NodeType
    • DhcpNodeType
    Note If the NodeType value is present, this value will override the DhcpNodeType value. If neither subkey is present and if no WINS servers are configured for the client, the computer uses b-node mode. If at least one WINS server is configured, the computer uses h-node mode.
  4. Quit Registry Editor.
  5. Restart the computer.
  6. Try to view workgroup computers on the network again.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

160177 Default node type for Microsoft clients

314053 TCP/IP and NBT configuration parameters for Windows XP


Modification Type:MajorLast Reviewed:8/9/2005
Keywords:kbtshoot kbprb KB903267 kbAudEndUser