Error message on a Windows 2000-based computer when you use Microsoft Client Service for NetWare to open a file on a Novell NetWare server: "This file could not be found" (902350)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Consider the following scenario. Microsoft Client Service for NetWare is installed on a Microsoft Windows 2000-based computer. From this computer, you try to open a file that is located in a mapped, shared folder on a Novell NetWare server. However, you cannot open the file. Instead, you receive the following error message:
This file could not be found.
Note You can open the file if one of the following conditions is true:
  • You start the program in which you created the file, click Open on the File menu, locate the file in the shared folder, and then click Open.
  • You run Novell Client services instead of Microsoft Client Service for NetWare.

CAUSE

This problem occurs if the path of the file that you want to open contains the following:
  • Long folder names
  • Short folder names that use the 8.3 file naming format
For example, this problem occurs if the following conditions are true:
  • The file is stored in the following location:

    \\ComputerName\ShareName\FolderWithLongName\FolderWithShortName\FolderName

  • You map a drive to the following folder:

    \\ComputerName\ShareName\FolderWithLongName

In this scenario, an incorrect NetWare Core Protocol (NCP) call retrieves the file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Nwrdr.sys5.0.2195.7059161,48805-Jul-200506:09x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about a hotfix that fixes a similar issue that occurs in Microsoft Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

816074 Client Service for NetWare does not open files on a Novell 4.11 server

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:7/26/2006
Keywords:kbWin2000preSP5fix kbExpertiseInter kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB902350 kbAudITPRO