You receive a time-out error message if you use a multilink ISDN connection (900908)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition

SYMPTOMS

If you start an Integrated Services Digital Network (ISDN) connection, the callback of the ISDN connection to a CISCO router fails on the second channel. Additionally, the client shows that one channel is connected, and you receive an error message that is similar to the following error message:
Error 683: The request has timed out.

CAUSE

The issue occurs because the CISCO router time-out setting for ISDN connections is too short.

WORKAROUND

To work around this issue, use the ppp timeout retry a number of seconds between 1 and 255 command to increase the time-out setting. The ppp timeout retry a number of seconds between 1 and 255 command increases the period of time that the CISCO router waits for a response from the remote client before the CISCO router retransmits a connection termination request.

MORE INFORMATION

By default, a CISCO router waits 24 seconds before the CISCO router stops a connection if no Point-to-Point Protocol (PPP) packet is received. Generally, the following process takes more than 24 seconds to finish:
  1. Establish a PPP connection on the first channel.
  2. Disconnect the connection.
  3. Wait for the callback.
  4. Establish the PPP connection on the first channel again.
Windows-based clients that are configured for multilink start the PPP negotiation on the second channel only after the callback on the first channel has succeeded.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:7/1/2005
Keywords:kbtshoot kb3rdparty kbprb KB900908 kbAudEndUser kbAudITPRO