When you disconnect and then reconnect a network adaptor on a Windows XP-based computer, the IPsec policy is not applied for two to three seconds after the network adaptor is reinitialized (900624)



The information in this article applies to:

  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You may experience the following problem on a Microsoft Windows XP-based computer where a network adaptor uses the Internet Protocol security (IPsec) policy to restrict traffic to and from the computer. When you disconnect and then reconnect the network adaptor, the policy is not applied for two to three seconds after the network adaptor is reinitialized. Traffic that typically would be blocked by the IPSec policy may not be blocked.

CAUSE

This problem occurs because the network adaptor may initialize before the IPsec policy is applied. This problem occurs under certain conditions when you reinitialize an existing network adaptor.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows XP Service Pack 2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   ----------------------------------------------------------
   02-Jun-2005  03:04  5.1.2600.2689    75,136  Ipsec.sys
   02-Jun-2005  04:12  5.1.2600.2689   183,808  Ipsecsvc.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

This problem may occur only when you set the IP filter destination address to A specific IP Address in the Filter Properties dialog box. This problem does not occur when you set the IP filter destination address to My IP Address in the Filter Properties dialog box.

After you install the hotfix, add the EnablePnpFiltering registry value. Then, set the value to 1. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type EnablePnpFiltering, and then press ENTER.
  5. Double-click EnablePnpFiltering, type 1 in the Value data box, and then click OK.
  6. Quit Registry Editor.
  7. Restart the computer.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB900624 kbAudITPRO