"ESENT" and "Groveler" events are logged in the Application log when you use the Remote Installation Services component in Windows Server 2003 (900617)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

Consider the following scenario:
  • The Remote Installation Services (RIS) component is installed on a Microsoft Windows Server 2003-based computer.
  • You try to use the RIS volume on the Windows Server 2003-based computer to store CD-ROM-based images or Remote Installation Preparation (RIPrep) images.
In this scenario, the following events are logged in the Application log: Event Type: Error Event Source: ESENT Event Category: Transaction Manager Event ID: 623 User: N/A Computer: Computer_name Description: grovel (1344). The version store for this instance (0) has reached its maximum size of 2Mb. It is likely that a long-running transaction is preventing cleanup of the version store and causing it to build up in size. Updates will be rejected until the long-running transaction has been completely committed or rolled back. Possible long-running transaction: SessionId: 0x03390280 Session-context: 0x00000000 Session-context ThreadId: 0x00000558 Event Type: Error Event Source: Groveler Event Category: None Event ID: 12292 User: N/A Computer: Computer_name Description: The groveler on partition d:\ has failed due to a database error. See ESENT event log entries for details.

CAUSE

This issue occurs because the RIS Groveler service tries to perform cleanup work on a transaction that is too large to process. The hotfix that is described in the "Resolution" section breaks up the single large transaction into several smaller transactions.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any oth er hotfixes. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
	
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.337      220,672  Grovel.exe       IA-64
   26-May-2005  01:57  5.2.3790.337      210,944  Sis.sys

Windows Server 2003, Itanium-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.2453     243,712  Grovel.exe       IA-64

Windows Server 2003, x64-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.2453     143,872  Grovel.exe       

Windows Server 2003, x86-based versions
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  00:10  5.2.3790.337       78,336  Grovel.exe       
   26-May-2005  00:10  5.2.3790.337       66,048  Sis.sys

Windows Server 2003, x86-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  00:51  5.2.3790.2453      81,920  Grovel.exe       

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kberrmsg kbBug kbHotfixServer kbQFE kbpubtypekc KB900617 kbAudITPRO