Event ID 1000 is logged one or more times in the Application log and users do not receive e-mail notification when content on the Web site changes in Windows SharePoint Services (900498)



The information in this article applies to:

  • Microsoft Windows SharePoint Services

SYMPTOMS

You experience the following symptoms in Microsoft Windows SharePoint Services:
  • The following event ID is logged one or more times in the Application log on the server:

    Type: Error
    Source: Windows SharePoint Services 2.0
    Category: None
    Event ID: 1000
    Description:
    #50070: Unable to connect to the database DatabaseName on SQLServerComputerName. Check the database connection information and make sure that the database server is running.

    For example, the placeholder DatabaseName may be for the STS_config database. The default name of the configuration database in Windows SharePoint Services is STS_config.
  • You configure the Alerts feature in Windows SharePoint Services to send e-mail notifications to notify users when content in the Windows SharePoint Services Web site changes. When an item is added to the Web site, an e-mail notification is sent to users who created an alert for that item. However, when an item is changed in the Web site, e-mail notifications are not sent to users who created an alert for that item.
  • Users who browse the Windows SharePoint Services Web site may not experience any unexpected issues.

CAUSE

This issue may occur if the user account to which the Windows SharePoint Services Timer Service is configured to log on does not have permissions to the configuration database. A user account may not have permissions to the configuration database if the following conditions are true in the order in which they are presented:
  • You change the user account that is configured as the application pool identity for the administration and content virtual servers in Windows SharePoint Services.
  • You do not synchronize the SharePoint Timer Service together with the new user account information.
For example, this issue may occur in the following scenario. You follow the steps in the following article in the Microsoft Knowledge Base to change the application pool identity for the Windows SharePoint Services administration and content virtual servers. However, you do not perform substep 3 of the "Step 5: Configure the user Account as the application pool identity for SharePoint Central Administration" section.

832770 How to change the application pool identity for Windows SharePoint Services administration and content virtual servers

RESOLUTION

To resolve this issue, synchronize the Windows SharePoint Services Timer Service together with the new user account information. To do this, follow these steps:
  1. Start Windows SharePoint Services Central Administration.
  2. On the Windows SharePoint Services Central Administration page, click Configure virtual server for central administration under Server Configuration.
  3. On the Configure Administrative Virtual Server page, click Use an existing application pool, click the existing application pool that you are already using, and then click OK.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

894632 E-mail notifications are not sent by SharePoint Portal Server 2003 or by Windows SharePoint Services when content on the portal site or content on the Web site changes

For more information about how to troubleshoot similar event ID 1000 messages, click the following article numbers to view the articles in the Microsoft Knowledge Base:

840685 An event ID 1000 error message is logged to the application event log when you restart Windows Small Business Server 2003

835225 You may experience problems when you search for content on SharePoint

843184 You may get unexpected search results or errors from a server farm with the Chinese (Traditional) version of the SharePoint Portal Server 2003


Modification Type:MinorLast Reviewed:7/28/2006
Keywords:kberrmsg kbtshoot KB900498 kbAudITPRO