FIX: You receive an "Access is denied" error message when you try to append a file that is hosted on IIS 6 by using the append command at an FTP prompt (900405) (900405)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0

SYMPTOMS

Consider the following scenario. You want to append one file to another file that is hosted on Microsoft Internet Information Services (IIS) 6. When you try to use the append command at an FTP prompt, you receive an error message that is similar to the following:
550 FileName: Access is denied.
Note In the error message, FileName is the name of the file to which you want to append another file.

This problem occurs even though you have the Create Folders/Append Data user right on the file.

CAUSE

This problem occurs because of a limitation in the FTP code.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

If you do not want to restart the computer after you apply this hotfix, stop all IIS services before you apply this hotfix. To do this, type the following command at a command prompt, and then press ENTER:

iisreset /stop

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 with Service Pack 1 for Itanium-based systems
  Date         Time   Version        Size     File name
  -------------------------------------------------------
  22-Jun-2005  16:04  6.0.3790.2471  338,432  Ftpsvc2.dll
Windows Server 2003 with Service Pack 1, x64 Editions
  Date         Time   Version        Size     File name
  -------------------------------------------------------
  22-Jun-2005  16:04  6.0.3790.2471  177,664  Ftpsvc2.dll   
Windows Server 2003 with Service Pack 1, x86 versions
  Date         Time   Version        Size     File name
  -------------------------------------------------------
  22-Jun-2005  15:36  6.0.3790.2471  127,488  Ftpsvc2.dll
Windows Server 2003 for Itanium-based systems
  Date         Time   Version       Size     File name
  ------------------------------------------------------
  22-Jun-2005  16:04  6.0.3790.354  313,344  Ftpsvc2.dll
Windows Server 2003, x86 versions
  Date         Time   Version       Size     File name
  ------------------------------------------------------
  22-Jun-2005  15:15  6.0.3790.354  119,808  Ftpsvc2.dll

WORKAROUND

To work around this problem, give the security account the Create Files/Write Data and Create Folders/Append Data user rights on the file.

To do this, follow these steps:
  1. In Windows Explorer, right-click the file for which you want to change the user rights, and then click Properties.
  2. Click the Security tab, and then click Advanced.
  3. Click the security account that you want to change, and then click Edit.
  4. Click to select the Create Files / Write Data Allow and Create Folders / Append Data check boxes, and then click OK three times.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbBug kbQFE kbHotfixServer kbpubtypekc KB900405 kbAudITPRO kbAudDeveloper