The body of an e-mail message is garbled when the header field and body field are set to different character sets in Exchange Server 2003 (900087)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition


Notice

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario.
  • An e-mail message has the header field and the body field set to different character sets.
  • The two different character sets do not belong to the same language group.
When you try to view the message by using Microsoft Outlook, the body of the message is garbled.

For example, a message has UTF-8 specified in the From field or in the To field. Additionally, the body of the message is encoded as ISO-8859-1. When you try to view it by using Outlook, the body of the message contains garbled characters.

CAUSE

This problem occurs because Microsoft Exchange Server 2003 sets the PR_INTERNET_CPID property to the UTF-8 character set. The PR_INTERNET_CPID property is a superset for any header field character set and body field character set. When a message uses two different language groups, Outlook tries to display the body of the message in UTF-8. Therefore, the body of the message is garbled.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size        File name
   ----------------------------------------------------------
   25-Aug-2005   01:55   6.5.7233.45   3,270,144   Mdbmsg.dll       
   04-Jun-2005   01:56                     3,304   Redir.asp
   25-Aug-2005   02:29   6.5.7233.45   5,177,856   Store.exe        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
After you install this hotfix, you must create the following registry key. To do this, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\MSExchangeIS\PARAMETERSSYSTEM\InternetContent
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the details pane, input the new value PreserveISO-8859CPIDBody, and then press Enter.
  5. Right-click PreserveISO-8859CPIDBody, and then click Modify.
  6. Under Base in the Edit DWORD Value dialog box, click Decimal.
  7. In the Value data box, type the value 1, and then click OK.
  8. Close Registry Editor.
This problem occurs only in Microsoft Exchange Server 2003 and only when the header field and the body field are set to different character sets.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbQFE KBHotfixServer kbexchSTORE kbfix kbBug kbpubtypekc KB900087 kbAudITPRO