You cannot connect to the Internet when you try to use a feature in Money that requires an Internet connection (899935)



The information in this article applies to:

  • Microsoft Money 2005 Deluxe
  • Microsoft Money 2005 Premium
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2005 Standard
  • Microsoft Money 2006 Deluxe Web Download English (United States)
  • Microsoft Money 2006 Premium Web Download
  • Microsoft Money 2006 Standard Web Download English (United States)
  • Microsoft Money Deluxe 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money Premium 2006

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

SYMPTOMS

You cannot connect to the Internet when you try to use a feature in Microsoft Money that requires an Internet connection. You may not be able to sign in by using the Microsoft Passport Network credentials, and the system asks if you want to work offline. Additionally, you may receive one of the following error messages:

Error message 1

Money does not detect an Internet connection.

Error message 2

Object Moved. This document may be found here.

http://URL
If you try to use online Help, or if you try to update Money, you receive the following error message:
Your signing information cannot be verified. Go online and re-enter your sign in information.
Alternatively, you may not be able to browse the Internet from Money, or you may not be able to connect to the Web site for your financial institution.

CAUSE

This issue may occur if a third-party firewall program is installed on the computer. Examples of third-party firewall programs include Norton Internet Security or McAfee Personal Firewall. Or, this issue may occur if you are behind an Internet proxy.

WORKAROUND

To work around this issue, use one or more of the following methods.

Method 1: Add Money to the Allow list in the firewall program

To work around this issue, add Money to the Allow list in the firewall program.

To add Money to the Allow list in the McAfee Personal Firewall program, follow these steps:
  1. Exit Microsoft Money.
  2. Start the McAfee Personal Firewall program.
  3. On the left side of the window, click Personal Firewall, and then click View the Internet Applications List.
  4. Click New Allowed Application, and then locate the folder where the Money executable file is located. By default, the Money executable file is located in the following folder:

    Drive_letter:\Program Files\Microsoft Money Version_number\MNYCoreFiles

    In this path, Version_number is the version of Microsoft Money that is installed.
  5. Click msmoney.exe, and then click Open.
  6. Click the new Microsoft Money entry in the Internet Applications list. Then click Allow Full Access in the Change Permissions pane.
  7. Exit the McAfee Personal Firewall program.
For information about how to add Money to the Allow list in other firewall programs, see the program documentation. Or, contact the vendor of the firewall program.

Method 2: Temporarily disable or remove the firewall program

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

If you continue to experience the issue that is mentioned in the "Symptoms" section after you add Money to the Allow list in the firewall program, verify that this issue occurs because of the firewall program. To verify this, temporarily disable or remove the firewall program.

For information about how to disable or remove the firewall program, see the program documentation. Or, contact the vendor of your firewall program.

Note To eliminate security issues, make sure that you only use this method as a test to verify that Money works as expected. After you verify that you can resolve this issue by disabling or removing the firewall program, make sure that you re-enable or reinstall the firewall program. Sometimes you can resolve the issue in Money by re-enabling or reinstalling the firewall program.

If Money works when you disable or remove the firewall program but does not work after you re-enable or reinstall the firewall program, contact the vendor of the firewall program to see whether they can provide steps to enable Money to work correctly.

For information about how to contact the firewall program vendor, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Method 3: Clear the Temporary Internet Files folder

This issue may occur if the Temporary Internet Files folder contains any damaged or incompatible files. To clear the Temporary Internet Files folder, follow these steps:
  1. Start Microsoft Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the General tab, click Delete Files under Temporary Internet files.
  4. Click OK to confirm that you want to delete all the files in the Temporary Internet Files folder.

Method 4: Change the Internet connection to use HTTP 1.1 through proxy connections

If you are behind an Internet proxy, enable the HTTP 1.1 through proxy connections setting to work around this issue. You may be behind an Internet proxy if a server is running Microsoft Internet Security and Acceleration (ISA).

To enable this setting, follow these steps:
  1. Click Start, click Run, type inetcpl.cpl, and then click OK.
  2. Click the Advanced tab.
  3. Under HTTP 1.1 settings, click to select the following check box:

    Use HTTP 1.1 through proxy connections

  4. Click OK.

Method 5: Change the settings for the firewall

Norton Internet Security 2004

To block and permit categories of Internet programs, follow these steps:
  1. Click Start, point to Norton Internet Securities, and then click Norton Internet Securities.
  2. In the main Norton Internet Security window, double-click Parental Control.
  3. On the Settings For menu, click the account that you want to change. Then, click Programs.
  4. Under Program Categories, click the program categories that this account is permitted to use. Then, click OK.
To strictly control the ability of a program to access the Internet, add the program to Program Control. This overrides any settings that are made by Automatic Program Control. To add a program to Program Control, follow these steps:
  1. In the main Norton Internet Security window, double-click Personal Firewall.
  2. Click the Programs tab.
  3. Under Manual Program Control, click Add.
  4. Click the executable file for the program. (Executable file names typically end in .exe.)
  5. Click Open.
  6. In the Program Control alert dialog box, click the access level that you want this program to have. For any Microsoft Money listings, click Permit. Then, click OK.
To customize Program Control, follow these steps:
  1. In the main Norton Internet Security window, double-click Personal Firewall.
  2. Click the Programs tab.
  3. In the list of programs, click the program that you want to change, and then click Modify.
  4. In the Program Control alert dialog box, click the access level that you want this program to have. For any Microsoft Money listings, click Permit. Then, click OK.
To add a new Application rule, follow these steps:
  1. Open the list of rules. To do this, follow these steps:
    1. Start Norton Internet Security or Norton Personal Firewall.
    2. Double-click Personal Firewall.
    3. Click the Program Control tab. The list of Application rules is displayed.
  2. Add the rule. To do this, follow these steps:
    1. Click Add.
    2. In the Select a program dialog box, locate the executable file for the program that you want to add. Then, click the executable file for the program.
    3. Click Open. The NIS or NPF Program Control dialog box is displayed. This dialog box contains the following options:
      • Permit
      • Block
      • Manually configure Internet access
      .
    4. Click an option, and then click OK. The Application Category dialog box is displayed.
    5. Click a category, and then click OK. Your program is added to the list.
  3. Configure the rule. To do this, follow these steps:
    1. If you chose the Permit option or the Block option in step 2d, you have configured the rule. Go to step 4.
    2. If you chose the Manually configure Internet access option in step 2d, complete the information in the resulting dialog boxes to configure the rule. For more information about these options, click Overview of customization options.
  4. Click OK.
  5. Exit Norton Internet Security or Norton Personal Firewall.

Microsoft Windows Firewall

To set an exception in Microsoft Windows Firewall, follow these steps:
  1. Click Start, click Run, type wscui.cpl, and then click OK.
  2. Click Windows Firewall.
  3. Click the Exceptions tab.
  4. Click Add Program.
  5. Click Microsoft Money, and then click OK.
  6. Click OK, and then close the Windows Security Center dialog box.

McAfee Personal Firewall

To set an exception in McAfee Personal Firewall, follow these steps:
  1. Start McAfee Personal Firewall.
  2. Click Internet Applications.
  3. Locate Microsoft Money.
  4. Make sure that Money is set to Allow Full Access. If not, right-click the permission, and then click Allow Full Access.
  5. Add Microsoft Money. By default, Money is located in the following folder:

    Drive_letter:\Program Files\Microsoft Money Version_number

    In this path, Version_number is the version of Microsoft Money that is installed.
  6. After you add the exception, verify that it has been changed.
  7. Exit McAfee Personal Firewall.

Sygate Personal Firewall

To set an exception in Sygate Personal Firewall, follow these steps:
  1. Start Sygate Personal Firewall Pro.
  2. On the Tools menu, click Applications.
  3. Click Microsoft Money.
  4. Make sure that Money is set to Allow in the Access column. If not, right-click the setting, and then click Allow.
  5. Click OK.
For more information, download the Sygate Personal Firewall User Guide. To download this User Guide, visit the following Sygate Web site:

Zone Alarm

To set an exception in Zone Alarm, follow these steps:
  1. Start Zone Alarm.
  2. In the left pane, click Program Control.
  3. Click Programs.
  4. Click Microsoft Money, and then click Allow.
For more information, download the User Guide for Zone Labs security software. To download this User Guide, visit the following Zone Alarm Web site:

Tiny Firewall

For information about how to configure Tiny Firewall so that Microsoft Money can access the Internet, visit the following Tiny Software Web site:

eTrust EZ Firewall

To set an exception in eTrust EZ Firewall, follow these steps:
  1. Double-click the EZ Firewall icon in the notification area.
  2. Make sure that the Lock icon at the top is in the unlocked position.
  3. In the left pane, click Program Control.
  4. Click the Programs tab.
  5. Confirm that the permissions are set as follows:
    1. Locate Microsoft Money in the list of programs. Make sure that green check marks appear next to Access and next to Server.
    2. If the computer is running Microsoft Windows XP or Microsoft Windows 2000, locate Generic host process for win32 in the list of programs. Make sure that green check marks appear next to Access and next to Server.
    3. Locate Application Layer Gateway in the list of programs. Make sure that green check marks appear next to Access and next to Server.
  6. Try to access the Internet and update Money.
  7. If you cannot update Money, remove all instances of Microsoft Money and Generic host process for win 32 from the list of programs. To remove them, right-click the program name, and then click Remove.
  8. Try to update Money again. When you are prompted to allow access permissions for the processes that you removed in step 7, allow these permissions.
If this procedure does not resolve the issue, follow these steps:
  1. Restart the computer in Safe Mode.
  2. Double-click My Computer, and then open the folder where Windows is installed. By default, this folder is C:\Windows.
  3. Locate and then delete the Internet Logs folder.
  4. Restart the computer in Normal Mode.
  5. Reconfigure the firewall settings.
  6. Try to access the Internet and update Money.

BlackICE Defender

To turn off the Application Protection component in BlackICE Defender, follow these steps:
  1. On the Tools menu, click Edit BlackICE Settings.
  2. Click either the Application Control tab or the Communication Control tab.
  3. Click to clear the following check box:

    Enable Application Protection

To allow Microsoft Money to access the Internet in BlackICE Defender, follow these steps:
  1. On the Tools menu, click Advanced Application Protection Settings.
  2. Click Known Applications. Leave the Communications Control column blank.
  3. Click Save Changes.

PCSecurityShield firewall

To set an exception in PCSecurityShield firewall, follow these steps:
  1. Start the firewall.
  2. Click Control.
  3. Click Microsoft Money under Applications, and then click Edit.
  4. Click Allow All Traffic under Internet Access, and then click OK.
  5. Exit all programs that are currently open on the computer.
  6. Restart the computer.

Windows Defender Beta 2

  1. Click Start, click Run, type appwiz.cpl, and then press ENTER
  2. Select Windows Defender, and then click Remove.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/8/2006
Keywords:kbtshoot kbprb KB899935 kbAudEndUser