The Task Scheduler service may not start scheduled tasks on a Windows Server 2003-based computer (899649)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

On a Microsoft Windows Server 2003-based computer, the Task Scheduler service may not start scheduled tasks.

CAUSE

The problem occurs when the Terminal Services service is disabled. If the Terminal Services service is disabled, the Task Scheduler service uses different code to construct the token for running the task. The Task Scheduler service may reuse a handle that is already closed.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

WORKAROUND

To work around this problem, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. Right-click the Terminal Services service, and then click Properties.
  3. On the General tab, click Manual in the Startup type box.
  4. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in Windows Server 2003 Service Pack 1 (SP1).

REFERENCES

For more information about a similar issue in Microsoft Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

873345 Tasks that are scheduled to run when you log on to a Windows XP-based computer do not run after you apply security update MS04-022


Modification Type:MajorLast Reviewed:5/18/2005
Keywords:kbScheduler kbservicepack kbtshoot kbprb KB899649 kbAudITPRO kbAudEndUser