Microsoft Dynamics CRM does not use the default SMTP server to send e-mail messages (899584)



The information in this article applies to:

  • Microsoft CRM 3.0

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you change the Simple Mail Transfer Protocol (SMTP) server to the default SMTP server by using the repair functionality in Microsoft Dynamics CRM 3.0, Microsoft Dynamics CRM does not use the default SMTP server to send e-mail messages. This problem occurs if you selected an SMTP server that is not the default SMTP server when you installed the Microsoft Dynamics CRM server components.

CAUSE

The problem occurs because the settings that point to the previous server are retained in the registry.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM

  3. Delete the following registry entries under that registry subkey:
    • SMTPAuthenticate
    • SMTPServer
    • SMTPServerPort
    • SMTPUseSSL

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/22/2006
Keywords:kbMBSemail kbtshoot kbMBSMigrate kbprb KB899584 kbAudEndUser kbAudKnowledgeWorker kbAudITPRO