You receive a "Windows could not start due to an error while booting from a RAMDISK" error message when the PXE process tries to start the ADS deployment agent in Windows Server 2003 (899495)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

The Pre-Boot Execution Environment (PXE) process tries to start the Microsoft Windows Automated Deployment Services (ADS) deployment agent on a computer that is running Microsoft Windows Server 2003 with Service Pack 1. In this scenario, you may receive an error message that is similar to the following:

Windows could not start due to an error while booting from a RAMDISK. Windows failed to build a bootable RAMDISK IMAGE.
Additionally, an error message that is similar to one of the following is logged in the Application event log:
Event Type: Error
Event Source: ADSBUILDER
Event Category: None
Event ID: 774
Date: <date>
Time: <time>
User: N/A
Computer: <servername>
Description:
An error occurred during the building of an image for the product {e597073d-bca9-4935-8257-25530a5677d0} and client hash {0264f4ee-f2a4-98be-34fe-ad5d17282fe8}.
Error Code: 81070303Event Type: Error
Event Source:ADSBUILDER 
Event ID: 772
Date:<date>
Time:<time>
User:N/A
Computer: <servername>
Description: \windows\system32\hal.dll could not be located during installation of the device ACPIAPIC_MP. Please ensure that the repository is pointing at the binary directories that contain the missing binary file.

CAUSE

This problem occurs when you use Microsoft Windows Server 2003 Service Pack 1 (SP1) media to run the ADS 1.0 Setup program. The Builder service cannot build a bootable image for the deployment agent.

Note This issue may be caused by many different things. This article discusses only one possible cause.

WORKAROUND

To work around this problem, use the original release version of Windows Server 2003 media to install ADS 1.0.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:8/23/2005
Keywords:kberrmsg kbtshoot kbprb KB899495 kbAudITPRO