You receive a "The event log file is corrupt" error on a computer that is running Windows Server 2003 SP1, an x64-based version of Windows Server 2003, or Windows XP Professional x64 Edition (899416)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

After you install Microsoft Windows Server 2003 Service Pack 1 (SP1), an error message that is similar to the following may be logged in the System event log:
The event log file is corrupt.
The System event log is corrupted, and you cannot view other messages. If you clear the log and restart the computer, the log becomes corrupted again.

This problem also occurs when you install the following operating systems:
  • x64-based versions of Windows Server 2003
  • Microsoft Windows XP Professional x64 Edition
  • A version of Windows XP Professional x64 Edition that is built on the Windows Server 2003 SP1 code base
Note You can remotely view the corrupted System event log from a Windows Server 2003-based computer that does not have Windows Server 2003 SP1 installed.

CAUSE

This problem occurs because the network adaptor drivers do not correctly set the customer bit. When network adaptor drivers try to log their own events, corruption may occur in the System event log.

For information about how to set the customer bit, visit the following MSDN Web site:

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites There are no prerequisites. Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 with Service Pack 1 (SP1), x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  03:14  5.2.3790.2443      69,120  Eventlog.dll     
Windows Server 2003 with SP1, Enterprise Edition for Itanium-based Systems
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-May-2005  12:51  5.2.3790.2443     184,832  Eventlog.dll     IA-64
Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-May-2005  12:50  5.2.3790.2443     130,560  Eventlog.dll     

Note You must clear the corrupted log with the hotfix applied.

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites No prerequisites are required. Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Professional x64 Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-May-2005  12:50  5.2.3790.2443     130,560  Eventlog.dll     

Note You must clear the corrupted log with the hotfix applied.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix adds validation code to the Eventlog.dll file. This code keeps the System event log from becoming corrupted.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

REFERENCES

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB899416 kbAudITPRO kbAudDeveloper