You may receive a "Windows could not start due to an error while booting the RAMDISK" error when you try to start a Windows Server 2003-based computer into the Deployment Agent (899343)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

You try to start a Microsoft Windows Server 2003-based computer into the Deployment Agent by using the Windows Server 2003 Automated Deployment Services (ADS). In this scenario, you may receive the following error message on the destination computer:
Windows could not start due to an error while booting the RAMDISK. Windows failed to build a bootable RAMDISK image. System will reboot in 5 seconds

CAUSE

This problem may occur if the computer is using more than 32 PCI devices.

RESOLUTION

To resolve this problem, install this hotfix on the ADS server that is running the Deployment Agent Builder service.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows Server 2003 Service Pack 1 (SP1)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  03:23  5.2.3790.2443     325,120  Osloader.ntd

Hotfix installation instructions

To install the hotfix, follow these steps:
  1. Double-click the hotfix installer package.

    The Osloader.ntd file is extracted to a temporary folder in the root folder of %systemdrive%. For example, the Osloader.ntd file is extracted to a folder location that is similar to the following:

    c:\7d3c7dedd1efd4be3c41b1b4a180\Osloader.ntd

    Note The name of the temporary folder may vary.
  2. In Windows Explorer, locate the following folder:

    %systemdrive%\Program Files\Microsoft ADS\tftproot\nbs\boot\x86

    Note The %systemdrive% environmental variable specifies the drive letter of the drive that contains Windows. By default, this is drive C.
  3. In the x86 folder, rename the Ntldr file to Ntldrold.
  4. Copy the Osloader.ntd file from the temporary folder to the %systemdrive%\Program Files\Microsoft ADS\tftproot\nbs\boot\x86 folder.
  5. Rename the Osloader.ntd file to Ntldr.
  6. Restart the ADS services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kberrmsg kbQFE kbHotfixServer KB899343 kbAudITPRO