You cannot use Office Communicator 2005 to share a program on your computer (898856)



The information in this article applies to:

  • Microsoft Office Communicator 2005

SYMPTOMS

When you use Microsoft Office Communicator 2005 to share a program on your computer, you may notice that you cannot share the program. Additionally, you may also receive one of the following error messages when you invite participants to share your program or when a participant invites you to share their program:
Inviter side error: Cannot establish the data sharing session with username because the data sharing program is not configured or installed correctly.
Receiver side error: Cannot establish the data sharing session with username because the data sharing program is not configured or installed correctly.

CAUSE

This issue may occur if a program that runs on your computer is using port 1503. Communicator 2005 uses port 1503 to establish a connection. If this port is already being used by another program, Communicator 2005 cannot use this port to establish a connection. Therefore, you cannot send a request to invite participants to share your program. Similarly, you cannot receive any requests from participants who want to share their program.

RESOLUTION

To resolve this issue, identify the program that uses port 1503, and then close the program session to release port 1503. To do this, follow these steps:
  1. Open a command prompt.
  2. At the command prompt, type the following command, and then press ENTER:

    netstat -ao

    Note This command displays the following information:
    • All network connections.
    • All listening ports.
    • The process ID (PID) for each network connection.
  3. Identify the PID for the network connection that uses port 1503.
  4. At the command prompt, type the following command, and then press ENTER to close the command prompt

    exit

  5. Start Windows Task Manager.
  6. In Windows Task Manger, click the Processes tab.
  7. Verify that the PID column is present on the Processes tab. If you do not see the PID column on the Processes tab, follow these steps to add the PID column:
    1. On the View menu, click Select Columns.
    2. Click to select the PID (Process Identifier) check box, and then click OK.
  8. Locate and then click the process with the PID that you identified in step 3.
  9. Click End Process, and then click Yes to close the program session that uses port 1503.

Modification Type:MajorLast Reviewed:5/12/2005
Keywords:kbnetwork kbConfig kbtshoot KB898856 kbAudEndUser kbAudITPRO