Some e-mail messages that you send from the Internet are not delivered, and event ID 9537 is logged in Exchange Server 2003 Service Pack 2 (897570)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base: -

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you send e-mail messages from the Internet in a Microsoft Exchange Server 2003 Service Pack 2 (SP2) organization, some of the messages are not delivered. For each message that is not delivered, an event that is similar to the following is logged in the Application log:Event ID: 9537
Type: Information
Source: MSExchangeIS Mailbox Store
Category: Transport Delivering
Description: A duplicate message arrived on database" Storage_Group \ Mailbox_Store". Ignoring delivery of message (Internet Message Id=<message_ID> ) to /o= Organization/ou= Administrative_Group/cn=Recipients/cn= username

CAUSE

This problem may occur if the following conditions are true:
  • You send the message from the Internet to multiple Exchange Server 2003 recipients.
  • The sum of the Message ID and Submit Time fields in the Simple Mail Transfer Protocol (SMTP) message exceeds 255 bytes. This situation occurs when the message contains a very long Message ID field in the SMTP header.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all dependent services are automatically restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7650.233,351,04012-Jan-200603:15x86
Store.exe6.5.7650.235,249,53612-Jan-200604:23x86

Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

When you apply this hotfix, the Disable Duplicate Detection Over 255 bytes value is added to the registry. By default, this registry value is disabled. To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Right-click Disable Duplicate Detection Over 255 bytes, and then click Modify.
  4. In the Value data box, type 1, and then click OK.

    Note To disable the value and to return Exchange Server 2003 to its default behavior, type 0 in the Value data box, and then click OK.
  5. Exit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Information about changes to the Send As user right in post-Exchange Server 2003 SP2 hotfixes

After Exchange Server 2003 SP2 was released, a change was made to the security behavior of the Exchange Server Information Store service. This change affects how users assign the Send As user right. This change is included in all post-Exchange Server 2003 SP2 hotfixes that have a version number of 6.5.7650.23 or a later version number.

Before this change was made, if you assigned Full Mailbox Access user rights to a service account, the service was able to send messages as the owner of the mailbox in some circumstances. After this change was made, mailbox security granularity now requires that you explicitly assign the Send As user right.

Many third-party add-in programs and services send messages for Exchange Server users. These programs and services include mobile device synchronization services. These programs and services may not have been granted Send As user rights. Instead, they may rely on Full Mailbox Access user rights. After you apply this hotfix, a program or a service may no longer function correctly because the program or service account can no longer send messages for other users. For more information about how to assign the Send As user right to an account, click the following article number to view the article in the Microsoft Knowledge Base:

912918 Error message when an application tries to send a message as another user by using Exchange Server 2003: "Access denied"

For more information about Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages

REFERENCES

For more information about a similar issue in Microsoft Exchange Server 2003 Service Pack 1 or Microsoft Exchange 2000 Server, click the following article numbers to view the articles in the Microsoft Knowledge Base:

839268 Some of the messages are not delivered when you send several messages in Exchange Server 2003

843234 In a Microsoft Exchange 2000 Server organization, some e-mail messages are not delivered when an e-mail message is sent from the Internet to multiple Exchange 2000 recipients


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbHotfixServer kbQFE kbfix kbBug kbpubtypekc KB897570 kbAudITPRO