Remote users cannot communicate with other remote users or with internal users in Live Communications Server 2005 (897536)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition
  • Microsoft Office Live Communications Server 2005 Standard Edition

SYMPTOMS

You have the following Microsoft Office Live Communications Server 2005 deployment:
  • Your Live Communications Server topology supports remote user access.
  • Remote users directly connect to a Live Communications Server 2005 Standard Edition pool or to a Live Communications Server Enterprise Edition pool through a Live Communications Server Access Proxy. Remote users' traffic does not pass through an intermediate director.
  • Remote users who are enabled for Live Communications are configured to communicate with other remote users or with internal users in the enterprise by using instant messaging.
In this scenario, you may experience the following symptoms:
  • Live Communications Server logon information and presence information appear correctly for remote users. However, instant messages between a remote user and another remote user are not successfully transferred.
  • If you perform logging by using flat-file log files, you notice the following log file information on the Live Communications Server 2005 Standard Edition computer:

    Severity: warning
    Text: Unable to route the request
    Result-Code: 0xc3e9101f

CAUSE

This problem occurs if the following conditions are true:
  • The Live Communications Server enterprise does not have a director server deployed. Instead, the Access Proxy server connects directly to the Live Communications Server Standard Edition front-end server or directly to the Live Communications Server Enterprise Edition front-end server.
  • Users are enabled only for remote user access. In this scenario, users are not enabled for federation.
Note This problem may occur even if the Live Communications Server enterprise is enabled for federation.

WORKAROUND

To work around this problem, enable the users for federation in Live Communications Server 2005.

Note Do not disable the users for remote user access. The users must be enabled for federation in addition to remote user access.

To enable a user for federation, follow these steps:
  1. Start the Live Communications Server 2005 Microsoft Management Console (MMC) snap-in.
  2. Expand your forest, expand Domains, expand your domain, expand Live Communications servers and pools, expand your pool, and then click Users.
  3. In the right pane, right-click a user object, and then click Properties.
  4. Click to select the Enable federation check box.

    Note Do not click to clear the Enable remote user access check box.
  5. Click OK.

RESOLUTION

To resolve this problem, configure your Live Communications Server topology to include a director. For more information about how to configure a director, see the Live Communications Server 2005 Access Proxy and Director guide. To obtain the Live Communications Server 2005 deployment guides, and to obtain other Live Communications Server 2005 documentation, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For detailed information about how to enable and to configure federation in Live Communications Server 2005, see the appropriate sections in the following Live Communications Server 2005 deployment guides:
  • The "Enabling Remote Access and Federation in Your Internal Deployment" section of the Live Communications Server 2005 Access Proxy and Director guide.
  • The "Step 4 Configure Access Proxy for Federation and Remote User Access" section of the Live Communications Server 2005 Standard Edition Lab Quick Start guide.
To obtain the Live Communications Server 2005 deployment guides, and to obtain other Live Communications Server 2005 documentation, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:4/7/2005
Keywords:kbtshoot kbpending kbBug KB897536