FIX: Paged pool memory usage increases after you configure a BizTalk Messaging Services channel to use the SendLocalFile transport component in BizTalk Server 2002 (897063)



The information in this article applies to:

  • Microsoft BizTalk Server 2002
  • Microsoft BizTalk Server 2002 Enterprise Edition

SYMPTOMS

In Microsoft BizTalk Server 2002, you may configure a BizTalk Messaging Services channel to use the BizTalk Server SendLocalFile transport component as the primary transport component. When you do this, paged pool memory usage continuously increases on the computer that is running BizTalk Server 2002. In this scenario, the server may eventually stop responding to client requests because of a lack of available memory. When this problem occurs, the following event is logged in the System log:Event Type: Error
Event Source: Srv
Event Category: None
Event ID: 2020
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description: The server was unable to allocate from the system paged pool because the pool was empty.

For more information, see Help and Support Center at http://support.microsoft.com.
Data:
0000: 00 00 04 00 01 00 54 00 ......T.
0008: 00 00 00 00 e4 07 00 c0 ....ä..À
0010: 00 00 00 00 9a 00 00 c0 ....s..À
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........
0028: 02 00 00 00 ....

CAUSE

This problem occurs if you configure the BizTalk Server SendLocalFile transport component to use a specific user name and password. In a scenario where you configure the BizTalk Server SendLocalFile transport component to use a specific user name and password, BizTalk Server 2002 incorrectly keeps token handles to kernel token objects. This behavior causes the BizTalk Server Messaging service to leak two handles in user mode. The behavior also causes the BizTalk Server Messaging service to leak paged pool memory in the kernel for every message that is processed by the BizTalk Server SendLocalFile transport component.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next BizTalk Server 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have BizTalk Server 2002 Service Pack 1 (SP1) installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

815781 How to obtain the latest BizTalk Server 2002 service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk Server Messaging service when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -------------------------------------------------------
   04-Apr-2005  23:05  3.0.2542.0  561,424  Sharedcomp.dll 
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

WORKAROUND

To work around this problem, do not configure the BizTalk Server SendLocalFile transport component to use particular user credentials.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbbug kbfix kbHotfixServer kbQFE KB897063 kbAudDeveloper