An IMAP4 client is disconnected abruptly when you connect through a front-end server that is running Exchange 2000 Server (896898)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server

SYMPTOMS

When you use an Internet Message Access Protocol version 4rev1 (IMAP4) client to connect to your mailbox through a front-end server that is running Microsoft Exchange 2000 Server, the IMAP4 client is disconnected abruptly.

CAUSE

This problem occurs if the mailbox folder that is on the back-end Exchange server contains a corrupted message.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Before you apply this hotfix, you must install the following updates:
  • Microsoft Exchange 2000 Server Service Pack 3 (SP3)
  • The August 2004 Exchange 2000 Server post-Service Pack 3 update rollup
For more information about how to obtain these updates, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Eximap4.dll6.0.6617.6794,20810-May-200522:29x86
Febecfg.dll6.0.6617.6740,96010-May-200521:46x86
Iisif.dll6.0.6617.6732,76810-May-200522:29x86
Iisproto.dll6.0.6617.67135,16810-May-200510:00x86
Imap4fe.dll6.0.6617.67135,16810-May-200521:47x86
Imap4svc.dll6.0.6617.67126,97610-May-200522:29x86
Pop3fe.dll6.0.6617.6724,57610-May-200521:47x86
Pop3svc.dll6.0.6617.6773,72810-May-200522:27x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The front-end Exchange server uses the FETCH command to retrieve the messages from the back-end Exchange server. If a corrupted message is found in the mailbox store during the retrieval process, the process is stopped. Therefore, the front-end server disconnects the IMAP4 client.

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE KBHotfixServer kbfix kbExchange2000preSP4fix kbbug kbpubtypekc KB896898 kbAudITPRO