A truncated Samba server response causes an access violation in the Lsass.exe program on a Windows XP-based client computer (896725)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

Consider the following scenario. You have a Microsoft Windows XP-based client computer that is joined to a Samba domain controller. The version of the Samba server is earlier than version 3.0.12. If a program on the client computer makes a LsaLookupSids function call to the Samba server to look up more than 255 Security Identifiers (SIDs), the Samba server truncates the response to the LsaLookupSids function call. This truncated Samba server response causes an access violation in the Lsass.exe program on the client computer.

CAUSE

This problem occurs because the Samba server versions that are earlier than version 3.0.12 truncate the size of the return buffer to 255.

RESOLUTION

To resolve this problem, do any one of the following:
  • Upgrade the Samba server to version 3.0.12 or a later Samba version .
  • Apply the hotfix that is described in this article to the Windows XP-based client computer.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ----------------------------------------------------------
   24-Feb-2005  23:53  6.1.22.4       14,048   Spmsg.dll
   07-Apr-2005  13:02  5.1.2600.2649  616,960  Advapi32.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug KB896725 kbAudITPRO