The Client Health Monitoring Tool Ping test stops responding in SMS 2003 with Service Pack 1 (896717)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP1

SYMPTOMS

Consider the following scenario:
  • You install the Microsoft Systems Management Server 2003 Client Health Monitoring Tool.
  • You click to select the Ping clients check box and then click Run Now on the Schedule tab in the SMS Client Health Monitoring Tool dialog box.
In this scenario, the Ping test may stop responding. Additionally, you may receive the following exception error message in the ChService.log file:
Sync data from SMS Database Caught exception: System.Data.SqlClient.SqlException: String or binary data would be truncated. The statement has been terminated. at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at chc.chkSyncDB.SyncTable() Unable to sync data from SMS. Ping Test failed, will try again next schedule.
Note The ChService.log file is located in the Program Files\Microsoft SMS Client Health\Logs folder.

CAUSE

This problem may occur if the SMS 2003 Client Health Monitoring Tool finds an SMS site code that exceeds three characters. This site code is located in the SMS_Installed_Sites0 column in the System_SMS_Instal_ARR SQL table in the SMS site database.

A similar problem may also occur when the SMS 2003 Client Health Monitoring Tool finds an SMS unique identifier (GUID) that exceeds 64 characters in the SMS site database.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Dec-2003  19:41                        326  Ccmlog.xml
   27-Aug-2004  23:27  2.50.3120.1000    225,280  Chc.exe          
   30-Jul-2004  22:27                      8,615  Chc.xml
   23-May-2005  21:47  2.50.3120.1101    155,648  Chcservice.exe   
   25-Aug-2004  22:05                      3,533  Chstatusmessage.xml
   25-Mar-2003  12:00  5.2.3790.0         47,104  Sc.exe           
   24-Aug-2004  22:06                      2,384  Settings.xml
   23-Sep-2004  18:11                    542,720  Smsclienthealthtool-userguide.doc
   27-Aug-2004  19:58                     16,896  Clienthealthpivot.xls
   24-Aug-2004  22:10                        379  Clienthealthsum.html
        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE KBHotfixServer kbfix kbbug kbpubtypekc KB896717 kbAudITPRO