A user in a trusted external domain cannot log on to a Windows Server 2003-based domain even though the "Allow Cross-Forest User Policy and Roaming User Profiles" Group Policy setting is enabled (896683)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

A user in a trusted external domain cannot log on to a Microsoft Windows Server 2003-based domain, even though the Allow Cross-Forest User Policy and Roaming User Profiles Group Policy setting is enabled.

When this problem occurs, the Userenv.log file may contain an entry that is similar to the following:
USERENV(ec0.86c) 13:36:18:156 ProcessGPO: Deferring search for <LDAP://CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=nils,DC=com>
USERENV(ec0.86c) 13:36:18:484 GetMachineDomainDS: ldap_bind_s failed with 82
USERENV(ec0.86c) 13:36:18:500 GetGPOInfo: Leaving with 0

CAUSE

This problem occurs because the Group Policy object that contains the Allow Cross-Forest User Policy and Roaming User Profiles Group Policy setting fails when a Windows Server 2003-based domain has an external trust relationship with the domain to which the user belongs.

Note This issue does not occur when the trust relationship between the domains is a forest trust instead of an external trust.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions   Date         Time   Version             Size  File name
   -----------------------------------------------------------------
   09-Apr-2005  00:24  5.2.3790.306     757,248  Userenv.dll
Windows Server 2003 with Service Pack 1, 32-bit versions   Date         Time   Version             Size  File name
   -----------------------------------------------------------------
   09-Apr-2005  00:13  5.2.3790.2418    789,504  Userenv.dll
Windows Server 2003, x64-based versions   Date         Time   Version             Size  File name  Platform
   -----------------------------------------------------------------
   11-Apr-2005  04:59  5.2.3790.2418  1,069,056  Userenv.dll     x64
   11-Apr-2005  04:59  5.2.3790.2418    789,504  Wuserenv.dll    x86
Windows Server 2003, Itanium-based versions   Date         Time   Version             Size  File name  Platform
   -----------------------------------------------------------------
   11-Apr-2005  04:59  5.2.3790.306   1,546,752  Userenv.dll   IA-64
   11-Apr-2005  04:59  5.2.3790.306     757,248  Wuserenv.dll    x86
Windows Server 2003 with Service Pack 1, Itanium-based versions   Date         Time   Version             Size  File name  Platform
   -----------------------------------------------------------------
   11-Apr-2005  04:59  5.2.3790.2418  1,563,648  Userenv.dll   IA-64
   11-Apr-2005  04:59  5.2.3790.2418    789,504  Wuserenv.dll    x86
Note Windows Server 2003 Service Pack 1 is already included in the Windows Server 2003 x64 edition.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE kbpubtypekc KB896683 kbAudITPRO