You may be unable to open any console-based applications on a Windows Server 2003-based computer (896667)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When you use a Microsoft Windows Server 2003-based computer, you may be unable to open any console-based applications if you are logged on as an administrator. For example, you cannot open the Cmd.exe application and the Ping.exe application. Additionally, you may receive an error message that resembles the following:
The application failed to initialize properly (0xc0000142). Click on OK to terminate the application.

CAUSE

When you open a console-based application, the system assumes that the OEM_CHARSET value appears before other kinds of values when fonts are enumerated. However, this assumption is not always correct.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.387292,86412-Aug-200510:39x86
Windows Server 2003 with SP1, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2507297,47212-Aug-200511:08x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2507509,44011-Aug-200520:51x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.387766,97611-Aug-200520:51IA-64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2507814,59211-Aug-200520:51IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:8/24/2006
Keywords:kbWinServ2003preSP2fix kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB896667 kbAudITPRO