You receive a "Destination party not found" error message when you try to run the scenario in module 3 of the "Partner Management and Business Activity Monitoring" tutorial in BizTalk Server 2004 (896311)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition

SYMPTOMS

In Microsoft BizTalk Server 2004, when you try to run the scenario in module 3 of the "Partner Management and Business Activity Monitoring" tutorial, you receive the following error message:
OrderProcess.OrderService(65270963-3dea-9fe0-fcd4-20547da7368e), instance 0c36eaf3-94e2-4198-8809-3a1225eeef74 Destination party not found while attempting to send message 'MinPOAmountRequestMsg' to (s-1-5-7, OrganizationName).

Exception type: DestinationPartyNotFoundException

Exception from HRESULT: 0xC0C01665.

CAUSE

This issue occurs when the Logon property of the BizTalkServerIsolatedHost host is set to \UserAccount instead of LocalComputerName\UserAccount. BizTalkServerIsolatedHost is the default isolated BizTalk Server host.

This issue may occur when you run the BizTalk Server 2004 Configuration Wizard to set up BizTalk Server 2004 to run on a single computer. By default, when you run the Configuration Wizard, the Configuration Wizard creates the appropriate BizTalk Server group accounts for you. However, the Configuration Wizard may incorrectly set the Logon property of the BizTalk Server host to \UserAccount instead of LocalComputerName\UserAccount.

Note The Logon property of the host may also be set to a valid domain account. For example, the Logon property may be set to DomainName\UserAccount.

RESOLUTION

To resolve this issue, you must set the Logon property of the BizTalkServerIsolatedHost host to LocalComputerName\UserAccount. To do this, follow these steps:
  1. Click Start, click All Programs, click Microsoft BizTalk Server 2004, and then click BizTalk Server Administration.
  2. In the BizTalk Server Administration Console, expand Microsoft BizTalk Server 2004 (local), expand Hosts, and then click BizTalkServerIsolatedHost.
  3. In the result pane, right-click your local computer name, and then click Properties.
  4. In the Properties dialog box, click Change.
  5. In the Provide account information dialog box, type LocalComputerName\UserAccount in the Logon box.

    Note Replace LocalComputerName with your local computer name and replace UserAccount with your local user account name.
  6. In the Password box, type your local user account password, and then click OK two times.
Note After you set the Logon property to the correct local user account name, you must restart the BizTalk Server service.

MORE INFORMATION

For more information about Windows group and user accounts in BizTalk Server, see the online BizTalk Server 2004 documentation at the following Microsoft Developer Network (MSDN) Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:

872924 You must specify domain groups and user accounts when you install BizTalk Server 2004 in a multiple computer environment


Modification Type:MinorLast Reviewed:4/19/2005
Keywords:kbnofix kbtshoot kbprb KB896311 kbAudDeveloper kbAudITPRO