You cannot manually start the Automatic Updates service and you receive an "Error 1058" error message on a computer that is running Windows XP or Windows XP Tablet PC Edition 2005 (896224)



The information in this article applies to:

  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

On a computer that is running Microsoft Windows XP or Microsoft Windows XP Tablet PC Edition 2005, you cannot manually start the Automatic Updates service. When this problem occurs, you receive an error message that is similar to the following:
Could not start the Automatic Updates service on account name.

Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
Additionally, the following event is logged in the Event Viewer System log:
Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10005
Date: Date
Time: Time
User: UserName
Computer: ComputerName
Description:
DCOM got error "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. " attempting to start the service servicename with arguments "" in order to run the server: {E60687F7-01A1-40AA-86AC-DB1CBF673334}

For more information, see Help and Support Center at http://support.microsoft.com.
Note The features and components of Windows XP Service Pack 2 (SP2) are included in Windows XP Tablet PC Edition 2005.

CAUSE

This problem occurs if the Automatic Updates service is disabled for the current hardware profile.

RESOLUTION

To resolve this problem, follow these steps to enable the Automatic Updates service:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the right pane, double-click Automatic Updates.
  3. Click the Log On tab.
  4. In the You can enable or disable this service for the hardware profiles listed below box, click the current hardware profile, and then click Enable.
  5. Click Apply, and then click the General tab.
  6. Click Start, and then click OK.

REFERENCES

For more information about the "Error 1058" error message, click the following article number to view the article in the Microsoft Knowledge Base:

838428 "Could not start the Remote Procedure Call (RPC) Service. Error 1058" error message when you manually start the Remote Procedure Call service


Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbtshoot KB896224 kbAudITPRO kbAudEndUser