The window that launches a File Download dialog box unexpectedly closes when you try to download a file by using Internet Explorer in Windows XP Service Pack 2 (896017)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to download a file by using Microsoft Internet Explorer, you may experience the following symptom:

When you click Save, Open, or Cancel in the File Download dialog box, the window that launches the File Download dialog box unexpectedly closes.

CAUSE

This problem may occur if you are running Microsoft Windows XP Service Pack 2 (SP2). This problem occurs because of a change in behavior in Internet Explorer when it runs in Windows XP SP2.

The MIME handling feature is changed when it processes a download from a pop-up window. In this scenario, the MIME handling feature closes the pop-up window when the downloaded content is sent from the Web server by using the "content-disposition; attachment" HTTP header.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to apply the hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply the hotfix.

Hotfix replacement information

The hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   25-Mar-2005  05:46  6.0.2900.2640   1,484,800  Shdocvw.dll

Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Note This update is also included in cumulative updates starting after MS05-025 (883939). The cumulative update does not require the following steps to enable the changed behavior. The following registry changes are required only if you install this specific hotfix (896017).

After you install this hotfix and then restart the computer, you must configure a registry setting to enable the changes that this hotfix makes. To do this, follow these steps:
  1. Quit Internet Explorer if it is running.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl

    Note If the FeatureControl subkey does not exist, add it. To do this, follow these steps:
    1. Right-click Main, point to New, and then click Key.
    2. In the New Key #1 box, type FeatureControl, and then press ENTER.
  4. Right-click FeatureControl, point to New, and then click Key.
  5. In the New Key #1 box, type FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017, and then press ENTER.
  6. Right-click FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017, point to New, and then click DWORD Value.
  7. In the New Value # 1 box, type iexplore.exe, and then press ENTER.
  8. Right-click iexplore.exe, and then click Modify.
  9. In the Value data box, type 00000001, and then click OK.
  10. Quit Registry Editor.

WORKAROUND

To work around this problem, change the client HTML code to use a "target" value for the POST command that is sent to the server. For example, consider the following example code:
 <form method="POST" action="download.asp">
To work around this problem, change this example code to the following code:
 <form method="POST" action="download.asp" target="_top">

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbBug kbfix kbQFE kbHotfixServer KB896017 kbAudEndUser kbAudITPRO