You receive an "Error 2902. An internal error has occurred" error message or an "Installation unsuccessful" error message when you install an Office 2003 update on a computer that has Windows Installer 3.0 installed (895975)



The information in this article applies to:

  • Microsoft Office Professional Edition 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003

SYMPTOMS

When you install a Microsoft Office 2003 update on a computer that has Microsoft Windows Installer 3.0 installed, one of the following symptoms may occur:
  • If you install the Office 2003 update from the Office Download Center, you receive the following error message:
    Error 2902. An internal error has occurred.
    (ixfAssemblyCopy) Contact your Information Technology department for assistance.
    When you click OK, you then receive the following error message:
    The update cannot be applied.
  • If you install the Office 2003 update from Office Update Web site, you receive the following error message:
    Installation unsuccessful.
Additionally, the following text appears in the update log file:

MSI (s) (40:80) [20:32:24:923]: Product: Microsoft Office Professional Edition 2003 -- Error 2902. An internal error has occurred. (ixfAssemblyCopy ) Contact your Information Technology department for assistance.

Error 2902. An internal error has occurred. (ixfAssemblyCopy ) Contact your Information Technology department for assistance.

If you installed the Office 2003 update from the Office Download Center, the update log file is located in the following folder:

drive:\Documents and Settings\user_name\Local Settings\Temp\ohotfix

If you installed the Office 2003 update from the Office Update Web site, the update log file is located in the following folder:

drive:\Documents and Settings\user_name\Local Settings\Temp\OfficeUpdate

CAUSE

This issue may occur if the following conditions are true:
  • You installed the Microsoft .NET Framework 1.1 after you installed Office 2003.
  • Windows Installer 3.0 is installed.

    To determine the version of the Windows Installer that is installed on the computer, follow these steps:
    1. Click Start, click Run, type %windir% in the Open box, and then click OK.
    2. Double-click the System32 folder.
    3. Right-click the Msiexec.exe file, and then click Properties.
    4. On the Version tab, determine the version of the Windows Installer that you have installed.
    Note If you type Msiexec.exe /? in the Open box in step 1 and then click OK to determine the version of the Windows Installer that is installed, you may receive the following error message:
    Incorrect command line parameters
    This issue may occur if Msiexec.exe version 2.00.3790.0 is installed on the computer.

RESOLUTION

To resolve this issue, use one of the following methods. Then, try to install the Office 2003 update again.

Method 1: Install Windows Installer 3.1

For more information about how to install Windows Installer 3.1, click the following article number to view the article in the Microsoft Knowledge Base:

893803 Windows Installer 3.1 (v2) is available

Method 2: Repair your Office 2003 installation

To repair your Office 2003 installation, follow these steps:
  1. Click Start, click Control Panel, and then click Add or Remove Programs.
  2. Under Currently installed programs, click Microsoft Office 2003, and then click Change.
  3. Under Maintenance Mode Options in the Microsoft Office 2003 Setup dialog box, click Reinstall or Repair, and then click Next.
  4. Under Reinstall or Repair Office, click Detect and Repair errors in my Office installation, click to select the Restore my Start Menu Shortcuts check box, and then click Install.
For more information about how to repair or reinstall your Office 2003 installation, click the following article number to view the article in the Microsoft Knowledge Base:

821593 How to install or repair and reinstall Office 2003 programs and features

Method 3: Install the Microsoft .NET Framework 1.1 before you install Office 2003

Before you install Office 2003, install the Microsoft .NET Framework 1.1.

We recommend that you download the Microsoft .NET Framework 1.1 from the following Microsoft Windows Update Web site:

Method 4: Launch the Custom Maintenance Wizard

The Custom Maintenance Wizard is available for download from the Office 2003 Resource Kit Web site.

For system administrators

If you are a system administrator, and you have to update your client computers, use one of the following methods:
  • Use the Custom Maintenance Wizard. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    308263 How to create a Custom Maintenance Wizard file for updating installation options after you deploy a custom installation of Office

    1. Select the MSI file to be modified in step 2 of the wizard.
    2. In step 3 of the wizard, choose either Create a new CMW file or Open an existing CMW file.
    3. In step 4 of the wizard, provide a location for the new CMW file to be created.

      Note You only need to provide a location if you are creating a new file.
    4. In step 6, under each installed application that is listed, set the .NET Programmability Support feature to Run from my computer. Several Microsoft Office applications will not have this option, such as Microsoft Office InfoPath and Microsoft Office OneNote.
    5. Click the Finish button to exit the wizard.
  • Use the DisableFlyWeightPatching system policy.

    For more information about the DisableFlyWeightPatching system policy, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:2/10/2006
Keywords:kbsetup kbtshoot kbprb KB895975 kbAudEndUser kbAudITPRO