You receive the "Error -2147023645" error message when you try to change your password in Outlook Web Access (895925)



The information in this article applies to:

  • Microsoft Internet Information Services

SYMPTOMS

When you try to change your password by clicking Change Password in Microsoft Outlook Web Access, the operation fails. Additionally, you receive an error message that is similar to the following error message:
Error -2147023645

CAUSE

This behavior may occur if you log on to Outlook Web Access with a secondary user principal name (UPN), and then you try to change your password.

In these circumstances, the user ID that is passed to Microsoft Internet Information Services (IIS) is the secondary UPN. IIS does not support the Change Password feature when you use a secondary UPN.

RESOLUTION

To resolve this behavior, make sure that your primary UPN is passed to IIS when you click Change Password. Consider the following example:
  • Your primary domain is domain.one.
  • Your primary UPN is user1@domain.one.
  • Your secondary UPN is user1@domain.com.
  • Your NetBIOS name is domain.
To change your password in this example, use one of the following methods.

Method 1

  1. In Outlook Web Access, click Options, and then click Change Password.
  2. In the Domain box, type domain, or type domain.one.
  3. In the Account box, type user1.
  4. In the Old Password box, type your existing password.
  5. In the New Password box, type an appropriate password.
  6. In the Confirm New Password box, retype your new password.
  7. Click OK.

Method 2

  1. In Outlook Web Access, click Options, and then click Change Password.
  2. Leave the Domain box blank.
  3. In the Account box, type user1@domain.one.
  4. In the Old Password box, type your existing password.
  5. In the New Password box, type an appropriate password.
  6. In the Confirm New Password box, retype your new password.
  7. Click OK.

Modification Type:MajorLast Reviewed:3/29/2005
Keywords:kbtshoot kbprb KB895925 kbAudEndUser