You receive the "An error has occurred in the script on this page" error message when you create a new phone call activity or a new letter activity in Microsoft Business Solutions CRM Sales for Outlook (895608)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft Business Solutions CRM 1.0
  • Microsoft Business Solutions CRM 1.0

SYMPTOMS

After you follow these steps in Microsoft Business Solutions CRM Sales for Outlook, also known as the Outlook client, you receive an error message:
  1. You create a new phone call activity or a new letter activity in the New Activity window.
  2. You click Save.
You receive the following error message:
An error has occurred in the script on this page.
Line: 144
Char: 1
Error: Object doesn't support this property or method.
Code: 0
URL: file://C:\Program Files\Microsoft CRM\Client\1033\Web\Activities\dlg_create.htm
You can successfully create a phone call activity or a letter activity in Microsoft Business Solutions CRM. You can also create a phone call activity or a letter activity in the Outlook client when you click Quick Create.

CAUSE

This problem occurs when the following schema fields are removed from the associated Microsoft CRM entity in Microsoft CRM System Customization:
  • address1_name
  • telephone1
The Phone Number box for the phone call activity and the Address box for a letter activity are automatically populated. The Outlook client uses the data that is entered in the associated Microsoft CRM entity to populate these boxes. For example, if you remove the address1_name schema field or the telephone1 schema field from the Contact entity, you experience the problem that is mentioned in the "Symptoms" section.

WORKAROUND

To work around this problem, you must add the fields to the associated Microsoft CRM entity. To do this, follow these steps.

Note These steps add the address1_name field to the Account form.
  1. In Microsoft CRM, click Home, click Settings, click System Customization, click Accounts, and then click Customize Form.
  2. Click Add Fields, click to select the Address Name check box, and then click OK.
  3. Click Save and Close.
  4. Publish the customization in Microsoft CRM Deployment Manager. To do this, click Start, point to All Programs, point to Microsoft CRM, and then click Deployment Manager.
  5. Right-click Deployment Manager, point to All Tasks, and then click Publish Customizations.
  6. Click to select the Account check box, click Next, and then click Add. Double-click the name of the Microsoft CRM server, and then click Finish.
  7. Reset Microsoft Internet Information Services. To do this, click Start, click Run, type iisreset, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft CRM 1.2 Sales for Outlook.

MORE INFORMATION

Steps to reproduce the behavior

  1. In Microsoft CRM, click Home, click Settings, and then click System Customization.
  2. Double-click the Contacts entity.
  3. In the Common Tasks section, click Customize Form.
  4. Locate the following schema fields in the form:
    • address1_name
    • telephone1
  5. Click address1_name, and then click Remove. Click OK after you receive the following message: Are you sure you want to remove the field from the form?
  6. Click telephone1, and then click Remove. Click OK after you receive the following message: Are you sure you want to remove the field from the form?
  7. Click Save and Close.
  8. Click Start, point to Run, type iisreset, and then click OK.
  9. Open the Outlook client.
  10. Open a contact record.
  11. Click the Activities tab, click New Activity, click Phone Call or Letter, and then click OK.

Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbMBScustomization kbMBSMigrate kbBug KB895608 kbAudEndUser