The Mailbox Management report shows incorrect free space (895178)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)

SYMPTOMS

If you configure the Exchange Server 2003 server to let the Mailbox Management process send a detailed report to you, you may find the Mailbox Management report shows incorrect free space.

The Mailbox Management report may show "null" instead of kilobytes (KB) or megabytes (MB). Additionally, the data size may be incorrect. For example, the Mailbox Management report may show the following information:
Folder/ Done: 0 Items Processed, 0 Items Would Be Moved or Deleted (0 (null))
Folder/Inbox Done: 0 Items Processed, 5 Items Would Be Moved or Deleted (17 (null))

CAUSE

This problem occurs after you apply the hotfix that is described in Microsoft Knowledge Base article 895471 or if you install Exchange Server 2003 Service Pack 1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

895471 Event ID 9307 displays an incorrect value for the number of messages that are moved or that are deleted by the Mailbox Management process in Exchange Server 2003 or in Exchange 2000 Server

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mad.exe6.5.7233.528,923,64807-Oct-200502:46x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:11/28/2005
Keywords:kbexchESM kbQFE kbBug kbfix KB895178 kbAudITPRO