After you repair or update ISA Server 2004, the ISA Server 2004 firewall service may not start on a Windows Server 2003-based computer that has been upgraded from Windows 2000 Server (895136)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition

SYMPTOMS

After you upgrade your computer from Microsoft Windows 2000 Server to Microsoft Windows Server 2003, the Microsoft Internet Security and Acceleration (ISA) Server 2004 firewall service may not start. The ISA Server 2004 firewall service may not start after you perform one of the following actions:
  • You repair ISA Server 2004.
  • You install ISA Server 2004 Service Pack 1 (SP1).
  • You apply an ISA Server 2004 hotfix.

CAUSE

This issue occurs because the Network Service account does not have permission to access Microsoft SQL Server 2000 Desktop Engine (MSDE). Therefore, the firewall service does not have access to MSDE.

Note When ISA Server 2004 is installed on a computer that is running Windows Server 2000, MSDE runs under the Local System account. After you upgrade to Windows Server 2003, MSDE continues to run under the Local System account. After you perform any one of the actions that is described in the "Symptoms" section, the ISA Server 2004 firewall service runs under the Network Service account.

WORKAROUND

To work around this problem, use the ISA Server 2004 Installation Wizard to uninstall and reinstall MSDE. To do this, follow these steps:
  1. Click Start, click Run, type appwiz.cpl in the Open box, and then click OK.
  2. In the Add or Remove Programs window, click Microsoft ISA Server 2004, and then click Change/Remove.
  3. In the Microsoft ISA Server 2004 Installation Wizard, click Next.
  4. On the Program Maintenance page, click Modify, and then click Next.
  5. On the Custom Setup page, expand Firewall Services, and then click Advanced Logging.
  6. Click This feature will not be available.
  7. Click Next, and then click Install.
  8. On the Installation Wizard Completed page, click Finish, and then close the Internet Explorer window that automatically opens.
  9. Repeat steps 1 through 5, and then click This feature will be installed on local hard drive.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:4/5/2005
Keywords:kbFirewall kbUpgrade kbtshoot kbprb KB895136 kbAudDeveloper