Windows Messenger 5.1 tries to repair itself when you copy or paste data from an Office program, open Adobe Acrobat Reader, or use MSN Messenger (894867)



The information in this article applies to:

  • Microsoft Windows Messenger 5.1

SYMPTOMS

Consider the following scenario, which affects Microsoft Windows Messenger 5.1. You do one or more of the following things:
  • Copy data or paste data from a Microsoft Office program.
  • Open Adobe Acrobat Reader to view a .pdf file.
  • Use the Application Sharing feature or send an instant message to a mobile user in Microsoft MSN Messenger.
You experience one or more of the following symptoms:
  • Windows Messenger 5.1 tries to repair itself. You receive the following message in a Windows Messenger 5.1 dialog box:Please wait while Windows configures Windows Messenger 5.1If you click OK or Cancel in the dialog box, the dialog box remains displayed on the screen.
  • Event ID 11935 is logged by the MsiInstaller component to the Application log.
  • You receive the following error message:
    An error occurred during the installation of assembly component {B2A34B25-54A3-446F-976B-C3BC2768D95C}. HRESULT: 0x80070020
  • If you are using MSN Messenger to send an instant message, you receive the following error message:
    Your invitation was not sent because you need the latest version of Windows Messenger to use the Application Sharing feature. Please go to the Windows Messenger update site to install the latest version.

CAUSE

This problem occurs because of an issue that exists with the Microsoft Windows Installer in Windows Messenger 5.1 that causes component rules to be broken.

RESOLUTION

To resolve this problem, reinstall Windows Messenger 5.1 by using the updated Messenger.msi file. To obtain the updated Messenger.msi file, visit the following Microsoft Web site:

WORKAROUND

To work around this problem, follow these steps:
  1. Do one of the following things:
    • Quit all programs that are running on the computer.

      Note To quit Adobe Acrobat Reader, you may have to start Windows Task Manager and then end the AcroRd32.exe process. To do this, follow these steps:
      1. Press CTRL+ALT+DELETE, and then click Task Manager.
      2. Click the Processes tab, click AcroRd32.exe, and then click End Process.
    • Restart the computer.
  2. Verify that MSN Messenger is not running on the computer. To do this, make sure that the MSN Messenger icon is not displayed on the taskbar or in the notification area, at the far right of the taskbar.
  3. Start Windows Messenger 5.1. To do this, click Start, point to All Programs, and then click Windows Messenger.

    Windows Messenger 5.1 starts and then repairs itself.
Note If you plan to deploy Windows Messenger 5.1 by using a silent installation, make sure that MSN Messenger is not running. After Windows Messenger 5.1 is installed on client computers, instruct users to start Windows Messenger 5.1 by using the Start menu when they start Windows Messenger 5.1 for the first time. That is, have users click Start, point to All Programs, and then click Windows Messenger.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about what occurs when component rules are broken, see the "An author removes resources from a component without changing the component code" topic on the following Microsoft Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/28/2005
Keywords:kbpending kbBug kbtshoot KB894867 kbAudITPRO kbAudEndUser