No contacts are returned in the search results when you use the Advanced Find feature with the Tomorrow condition in Microsoft CRM 1.2 (894383)



The information in this article applies to:

  • Microsoft CRM 1.2

SYMPTOMS

You experience the following behavior when you use the Advanced Find feature in Microsoft Business Solutions CRM 1.2. You specify the Tomorrow condition in your query to search for contacts who have a birthday or an anniversary that occurs on tomorrow's date. However, when you click Go to run the query, no contacts are returned in the search results. This behavior occurs even though one or more contacts have a birthday on tomorrow's date.

This behavior occurs when you follow these steps:
  1. You click Contacts in the Find in box.
  2. You click Birthday in the Field box.
  3. You click Tomorrow in the Condition box.
  4. You run the query.

CAUSE

When the Tomorrow condition is used in a query, the Advanced Find feature includes the day, the month, and the year in the date. Therefore, only records or activities that have a date that matches the day, the month, and the year for tomorrow's date are returned in the search results. Records or activities that have a date that occurs in a previous year are not returned in the search results.

STATUS

This behavior is by design.

WORKAROUND

To work around this behavior, change the year of the birthdays of contacts. Or, change the year of the anniversaries of contacts to the current year. To change the year of the birthday or the anniversary of a contact, follow these steps:
  1. Start Microsoft CRM 1.2, point to Sales or Services on the GoTo menu, and then click Contacts.
  2. Double-click the contact, and then click the Details tab.
  3. Under Personal Information, change the year that is displayed in the Birthday box or in the Anniversary box to the current year.
  4. Click Save and Close on the File menu.

Modification Type:MinorLast Reviewed:8/15/2005
Keywords:kbMBSMigrate KB894383 kbAudITPRO kbAudEndUser