You may be prompted to restart the computer when you use Device Manager to disable a hard disk in Windows Server 2003 (894090)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Storage Server 2003

SYMPTOMS

In Microsoft Windows Server 2003, when you use Device Manager to disable a hard disk, you may be prompted to restart the computer before the changes take effect.

CAUSE

This issue may occur if the hard disk is in the paging path.

RESOLUTION

A hotfix is available to resolve this issue. After you install this hotfix, you may not have to restart the computer after you disable a hard disk even when one or both of the following conditions is true:
  • The hard disk was recently removed from a software mirror in Logical Disk Manager.
  • The hard disk contains the system's paging file.
For example, in some hardware configurations, you may be able to use Device Manager to disable a hard disk and then replace the hard disk without restarting the computer. These hardware configurations may include a SCSI or Serial Advanced Technology Attachment (SATA) hard disk in a hardware backplane that is hot-plug capable.

Notes

  • After you apply this hotfix, you still have to restart the computer if you disable the hard disk that was mounted to start the operating system.
  • The new functionality that is included in this hotfix may only be available to you if your vendor-provided hot-plugging solution and your drive also supports the functionality. Contact the manufacturer of your hardware to determine whether your system supports the functionality. For information about how to contact the manufacturer of your hardware, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

    65416 Hardware and software vendor contact information, A-K

    60781 Hardware and software vendor contact information, L-P

    60782 Hardware and software vendor contact information, Q-Z

  • This hotfix does not provide hot-plugging support for SATA technologies in Windows Server 2003. This hotfix lets you disable a hard disk that is in the paging path under certain circumstances. This functionality depends on the hard disk controller and on other system technology. Contact your hardware vendor to see if your the system can perform these operations.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows Server 2003 Service Pack 1 (SP1) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   16-Apr-2005  00:59  5.2.3790.2423  150,528  Dmio.sys
   25-Feb-2005  03:51  6.1.22.4       371,936  Updspapi.dll
Windows Server 2003, Itanium-based versions
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   18-Apr-2005  02:40  5.2.3790.2423  534,528  Dmio.sys
   18-Apr-2005  02:40  6.1.22.4       639,712  Updspapi.dll
Windows Server 2003, x64-based versions
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   18-Apr-2005  02:40  5.2.3790.2423  244,224  Dmio.sys
   18-Apr-2005  02:40  6.1.22.4       462,560  Updspapi.dll

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbwinservsetup kbQFE kbHotfixServer kbstoragemgmt KB894090 kbAudITPRO