You receive a "Request timed out" error message when you use the Ping.exe command-line utility to verify network connectivity between Windows Server 2003-based NLB servers (894081)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

Consider the following scenario. You have multiple Microsoft Windows Server 2003-based Network Load Balancing (NLB) servers that have physical IP addresses in a cluster environment. You successfully use the Ping.exe command-line utility on one of the NLB servers to verify network connectivity with another NLB server. You perform this action by pinging the physical IP address of the second NLB server. Next, you disconnect and then reconnect the network cable on the first NLB server. Then, you use the Ping.exe command-line utility again to verify network connectivity with the remote NLB server. However, when you use the Ping.exe command-line utility this time, you receive the following error message:
Request timed out
Note This problem occurs only with certain specified cluster address and physical IP address combinations. For example, you experience this issue when the following conditions are true:
  • You try to ping an NLB server that has a cluster IP address of 172.23.9.129 and a physical IP address of 172.23.9.137.
  • The NLB server from which you perform this ping operation has the same cluster IP address (172.23.9.129).

CAUSE

This problem occurs because the order of the IP addresses that are stored in the ARPInterface structure is changed after you reconnect the network cable on the NLB server. Specifically, the first host sends an Address Resolution Protocol (ARP) request to resolve the second host's IP address. Therefore, ARP code searches the linked list in the ARPInterface structure for an address in which the network part of the address matches the network to which you want to send the ARP request. However, because the order of the IP addresses has changed, the ARP code finds the cluster address and then uses this as the source IP address.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix does not require any prerequisites.

Restart Requirement

You must restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
Date         Time   Version            Size    File name  Service pack
----------------------------------------------------------------------
14-Apr-2005  03:43  5.2.3790.309      336,896  Tcpip.sys   
14-Apr-2005  03:43  5.2.3790.2421     333,824  Tcpip.sys   Service Pack 1
  
Windows Server 2003, Itanium-based versions
Date         Time   Version            Size    File name  Service pack
----------------------------------------------------------------------
14-Apr-2005  11:07  5.2.3790.309      977,920  Tcpip.sys   
14-Apr-2005  11:07  5.2.3790.2421   1,111,552  Tcpip.sys    Service Pack 1
  
Windows Server 2003, x64-based versions
Date         Time   Version            Size    File name
--------------------------------------------------------------
14-Apr-2005  11:07  5.2.3790.2421     702,976  Tcpip.sys
  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Network connectivity between clients and servers may not work after you install the hotfix that is described in the "Resolution" section. This network connectivity issue is similar to an issue that you may experience after you install the MS05-019 security update. For more information about the network connectivity issue that is associated with the MS05-019 update, click the following article number to view the article in the Microsoft Knowledge Base:

898060 Installing security update MS05-019 or Windows Server 2003 Service Pack 1 may cause network connectivity between clients and servers to fail

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Steps to reproduce the problem

  1. Select two Windows Server 2003-based NLB servers. The configuration settings for these servers may be similar to the following :

    NLB 1 :
    Cluster IP address : 172.23.9.129
    Subnet Mask : 255.255.255.224
    Cluster Operation Mode : Multicast, Disable IGMP
    Host Dedicated IP address : 172.23.9.137

    NLB 2 :
    Cluster IP address : 172.23.9.129
    Subnet Mask : 255.255.255.224
    Cluster Operation Mode : Multicast, Disable IGMP Host
    Dedicated IP address : 172.23.9.136

  2. Log on to NLB 2, and then open a command prompt.
  3. At the command prompt, type ping -t 172.23.9.137, and then press ENTER.
  4. Remove the network cable from NLB 2.
  5. At the command prompt, try to run the ping command again. You receive a "Destination host unreachable" error message.
  6. At the command prompt, type arp -a, and then press ENTER to verify that the ARP table is clear.
  7. Reconnect the network cable on NLB 2.
  8. At the command prompt, type ping -t 172.23.9.137, and then press ENTER. You receive a "Request timed out" error message, even after network connectivity is restored.

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003SP1fix kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB894081 kbAudEndUser