Internet Explorer crashes if you click a button or scroll the view in Office InfoPath 2003 (893371)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows 98
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer version 6 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows XP, when used with:
    • Microsoft Office InfoPath 2003

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Microsoft Internet Explorer 6 crashes if you click a button or scroll through a page to view its contents. This symptom occurs if you use Microsoft Office InfoPath 2003 with Internet Explorer 6.

Note This problem also occurs if you use any other program that hosts the WebBrowser/MSHTML control with Internet Explorer.

CAUSE

This problem occurs if the InfoPath form changes at the same time that you interact with the form. Typically, this problem occurs if the view is switched at the same time that you click a button or you scroll through a page to view its contents. This problem also occurs if the database data updates the view at the same time that you click a button or you scroll through a page to view its contents.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6 for Microsoft Windows 2000 and Microsoft Windows XP

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Sep-2004  02:21  6.0.2800.1473      38,912  Iecustom.dll     
   08-Feb-2005  18:28  6.0.2800.1493     438,272  Mshtmled.dll     
   18-Nov-2004  17:45  6.1.22.0          371,936  Updspapi.dll   
	

Internet Explorer 6 for Microsoft Windows 98 and Microsoft Windows Millennium Edition

Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Mar-2003  16:24  6.0.2800.1172      33,792  Ieuninst.exe     
   01-Oct-2004  06:36  6.0.2800.1473      30,208  Ieupdate.exe     
   08-Feb-2005  18:28  6.0.2800.1493     438,272  Mshtmled.dll     

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Note This hotfix is included in the 896688 cumulative update for Internet Explorer. The following steps to set the registry key value are not required to enable this hotfix when the 896688 update is installed on the computer. For more information about the 896688 update, click the following article number to view the article in the Microsoft Knowledge Base:

896688 MS05-052: Cumulative security update for Internet Explorer

After you apply this hotfix, you must change the registry to turn the hotfix on. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. Right-click FeatureControl, point to New, and then click Key.
  4. Type FEATURE_CHECK_UNPOSITIONED_ELEMENT_KB893371, and then press ENTER to name the new entry.
  5. Click the new FEATURE_CHECK_UNPOSITIONED_ELEMENT_KB893371 registry subkey.
  6. On the Edit menu, click New, and then click DWORD Value.
  7. Type infopath.exe, and then press ENTER.
  8. On the Edit menu, click Modify.
  9. In the Value data box, type 00000001, and then click OK.
  10. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in Internet Explorer 6.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug kbHotfixServer KB893371 kbAudEndUser