FIX: "This action is only valid for products currently installed" error message after you install two major software updates for a product on Windows XP SP2 by using Windows Installer 3.0 (893048)



The information in this article applies to:

  • Microsoft Windows Installer 3.0
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)

SYMPTOMS

After you install two major software updates for a product on Microsoft Windows XP Service Pack 2 (SP2), any later installation operations are unsuccessful. When this problem occurs, you receive the following error message:
This action is only valid for products currently installed
Note A software update includes repairs, removals, or additional software update applications that you apply to the product. A major upgrade is a comprehensive update of a product that warrants a change in the ProductCode property.

CAUSE

This problem occurs when Microsoft Windows Installer 3.0 tries to find the wrong product. This problem is caused by a bug in the update sequencing.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time   Version        Size       File name
 --------------------------------------------------------------
25-Jan-2005   14:52  1.0.0.0       1,089,264   Windowsxp-kb893048-x86-enu.exe 
25-Jan-2005   14:50  1.0.0.0         929,520   Windowsxp-kb893048-x86-symbols-enu.exe
25-Jan-2005   17:12  3.0.3790.2601 2,804,736   Msi.dll
Note The Windowsxp-kb893048-x86-enu.exe file is the hotfix installer. The Windowsxp-kb893048-x86-symbols-enu.exe file is the installer for the hotfix symbol file that is named Msi.pdb. You do not have to install the Windowsxp-kb893048-x86-symbols-enu.exe file

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbprb kbHotfixServer kbQFE KB893048 kbAudITPRO kbAudDeveloper