Updates that are made to alerts in the destination management group may not be applied in the zone management group in Microsoft Operations Manager 2005 (892096)



The information in this article applies to:

  • Microsoft Operations Manager 2005

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

An alert update conflict may occur in Microsoft Operations Manager (MOM) 2005 when you use the MOM-to-MOM product connector to connect a source management group and a destination management group. Additionally, when you try to use multiple management groups in a multi-tiered configuration, updates that are made to alerts in the destination management group may not be applied in the zone management group. For example, the problem may occur if you modify the repeat count of an alert.

CAUSE

This problem occurs if the alert is updated separately in a source management group and in a destination management group in the same polling period. By default, the source management group update takes precedence. The update in the destination management group is dropped when a conflict occurs.

RESOLUTION

A hotfix is available that lets a MOM 2005 administrator modify the MOM 2005 configuration so that the destination management group update takes precedence when an alert update conflict occurs.

After you apply this hotfix and set a registry key on all source Management Servers, the default behavior is reversed. When an alert update conflict occurs, a change in the destination management group takes precedence over a change in the source management group. However, changes in the source management group are not applied in the destination management group when a conflict occurs.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Install this hotfix on computers that meet all the following conditions:
  • The computer hosts a MOM Management Server in the source management group.
  • The computer has MOM-to-MOM product connector installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, this hotfix restarts the MOM service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Mar-2005  07:42  6.0.2900.2180     150,248  Mom2005-rtm-kb892096-x86-enu.exe  

After the hotfix is installed, the following files will have the listed attributes or later file attributes:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Mar-2005  09:18  5.0.2749.17       61,440   MomConn.exe  

Installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To install the hotfix, follow these steps:
  1. Copy MOM2005-RTM-KB892096-X86-ENU.EXE to a local folder or to a network shared folder. If you use a network shared folder, make sure that you can access the folder from the computers that require this hotfix.
  2. Log on as an administrator to one of the computers that requires this hotfix.
  3. Run MOM2005-RTM-KB892096-X86-ENU.EXE on each applicable computer that meets the predefined criteria. You can run the file at a command prompt or use Windows Explorer to run the file.
  4. Repeat steps 2 through 3 on each computer that requires this hotfix.

After you install the hotfix, add a registry value to each computer that has this hotfix installed. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey:

    HKEY_LOCAL_MACHINE\Software\Mission Critical Software\MomConn

  3. Click the Edit menu, point to New, and then click DWORD Value.
  4. In the right pane, type TopTierConflictResolution as the name of this new registry entry.
  5. Double-click this new registry entry, type 1 in the Value data field, and then click OK.
  6. Restart the MOM-to-MOM Connector service.
To revert to the default behavior where changes in a source management group take precedence over changes in a destination management group, set the TopTierConflictResolution registry entry to 0. Or, remove the registry entry. Then, restart the MOM-to-MOM Connector service.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbExpertiseInter kbMOMpre2005SP1fix kbOpman2005spfix KB892096 kbAudITPRO