You receive a "Printer Driver was not installed" error message when you try to remotely install the first printer on a Windows Server 2003-based domain controller (891721)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When you use an account that is a member of the Print Operators security group to remotely install the first printer on a Microsoft Windows Server 2003-based domain controller, you receive the following error message:
Printer Driver was not installed. The operation could not be completed.

CAUSE

This problem occurs because members of the Print Operators security group cannot initiate file sharing for a server resource. Therefore, a member of the Print Operators group cannot create the "print$" printer share that is typically created when the first shared printer is installed.

Note If you apply the hotfix, the printer share is created in the security context of the system.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must apply this hotfix on a Windows Server 2003-based domain controller.

Restart requirement

You must restart the Print Spooler service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Feb-2005  22:38  5.2.3790.262      312,320  Localspl.dll     
   02-Feb-2005  22:38  5.2.3790.262       81,920  Spoolss.dll 
Microsoft Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Feb-2005  22:38  5.2.3790.262      312,320  Localspl.dll     
   02-Feb-2005  22:38  5.2.3790.262       81,920  Spoolss.dll 

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.
This bug was corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB891721 kbAudITPRO