The installation process stops responding when you install Visual Studio 2005 or Visual Studio .NET (891404)



The information in this article applies to:

  • Microsoft .NET Framework 2.0
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 1.0
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition

SYMPTOMS

When you try to install Microsoft Visual Studio 2005 or Microsoft Visual Studio .NET, the installation process may stop responding (hang).

CAUSE

This issue can occur if third-party firewall software is installed on your computer.

RESOLUTION

To resolve this issue, use the appropriate method for your operating system.

Microsoft Windows XP or Microsoft Windows Server 2003

To resolve this issue on a Microsoft Windows XP or Microsoft Windows Server 2003-based computer, use the System Configuration utility (Msconfig.exe) to turn off any third-party firewall programs that load at startup on your computer. To do this, follow these steps:
  1. Click Start, click Run, type Msconfig, and then click OK.
  2. On the General tab, click Selective Startup, and then click to clear the Load System Services and Load Startup Items check boxes.
  3. On the Services tab, click Service, and then click to clear the Machine Debug Manager and Windows Installer check boxes.
  4. Click Apply, click Close, and then click Restart.
  5. If the Windows Product Activation dialog box appears after your computer restarts, click No.
  6. If the System Configuration Utility dialog box appears, read the message, and then click OK.
  7. If the System Configuration Utility dialog box appears, click Cancel. If you are prompted to restart your computer, click Exit Without Restart.
  8. Run the Setup program again.
  9. After the Setup program is finished, click Start, click Run, type Msconfig, and then click OK.
  10. On the General tab, click Normal, click Apply, click Close, and then click Restart.

Microsoft Windows 2000

To resolve this issue on a Microsoft Windows 2000-based computer, use one of the following methods:

Method one: Copy Msconfig.exe from a Windows XP-based computer

Copy Msconfig.exe from a Windows XP-based computer to your Windows 2000-based computer. By default, Windows 2000 does not include Msconfig.exe.

Method two: Manually disable any firewall related services

Manually disable any firewall-related services. To do this, follow these steps:
  1. Click Start, click Run, type Services.msc, and then click OK.
  2. Right-click a firewall-related service, and then click Properties.
  3. In the Startup type list, click Disabled, and then click OK.
  4. Repeat steps 2 and 3 for each firewall-related service that is running on your computer.
  5. Restart your computer, and then start the installation process again.
  6. After the installation is complete, click Start, click Run, type Services.msc, and then click OK.
  7. Right-click a firewall-related service, and then click Properties.
  8. In the Startup type list, click the startup type you want, and then click OK.
  9. If you must restart your computer to start the firewall services, do so.

WORKAROUND

To work around this issue, remove the firewall software from your computer.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/3/2006
Keywords:kbvs2005swept kbvs2005applies kbtshoot kbprb KB891404 kbAudDeveloper