You may receive an error message when you click the Settings tab on the Display Properties dialog box in Windows XP (891387)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you open the Display Properties dialog box and then click the Settings tab in Microsoft Windows XP, you may receive the following error message:
The currently selected graphics display driver cannot be used. It was written for a previous version of Windows, and is no longer compatible with this version of windows. The system has been started using the default VGA driver. Please contact your hardware manufacturer to get an updated driver, or select one of the Microsoft provided drivers.
You may receive this error message if the following sequence of events occurs:
  1. You are using a portable computer that is connected to a docking station, and you are using an external monitor.
  2. You turn on the extended desktop function on the external monitor.
  3. You change the rotation setting on the external monitor by using your video adapter's display settings.
  4. You disconnect the portable computer from the docking station.
  5. You open the Display Properties dialog box and then click the Settings tab.

CAUSE

This problem may occur if the following sequence of events occurs:
  1. You use a third-party program to change the rotation of the external display that is connected to the docking station.
  2. You remove the portable computer from the docking station.
When this sequence of events occurs, the user profile is changed, and a mode that matches the display rotation cannot be located in the undocked profile.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this Hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP, 32-bit versions
   Date         Time   Version        Size     File name
   ------------------------------------------------------------------
   22-Mar-2005  22:21  6.0.2800.1650  384,000  Themeui.dll
Windows XP Professional x64 Edition
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   22-Mar-2005  22:21  6.0.2800.1650  939,520  Themeui.dll   IA-64
   22-Mar-2005  22:21  6.0.2800.1650  384,000  Wthemeui.dll  x86
   25-Feb-2005  03:50  6.1.22.4       639,712  Updspapi.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kberrmsg kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug kbQFE kbHotfixServer KB891387 kbAudEndUser