You cannot save or delete a recurring appointment in Exchange 2000 (891082)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you try to save or delete a recurring appointment in Microsoft Exchange 2000 Server, the appointment is not saved or deleted. You also receive the following error message:
Out Of Memory
Additionally, an Error event that is similar to the following Error event is logged in the Application log:Event Type: Error
Event Source: EXCDO
Event Category: General
Event ID: 8207
Date: Date
Time: Time
User: N/A
Computer: Server_Name
Description: Calendaring agent failed with error code 0x8007000e while deleting appointment. For more information, click http://search.support.microsoft.com/search/?adv=1. Note The description in this event varies depending on whether you tried to save or whether you tried to delete the appointment.

CAUSE

This problem occurs when the following conditions are true:
  1. There are too many recurring appointments in the calendar of one mailbox.
  2. You used Microsoft Outlook Web Access or any Document Authoring and Versioning (DAV) tool to access the calendar at least one time.
The RMTable property limits the number of appointments to 1360 appointments or to 32 kilobytes of appointment data. When the limit has been reached, the RMTable property cannot be opened. Therefore, new appointments cannot be saved, and existing appointments cannot be deleted.

RESOLUTION

After you install this hotfix, you can delete old recurring appointments so that the number of recurring appointments in the calendar is below the limit. After you delete the old recurring appointments, you can save new recurring appointments.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3) and the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previous hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Feb-2005  03:59  6.0.6617.44     3,919,872  Cdoex.dll        
   08-Feb-2005  03:59  6.0.6617.44     3,596,288  Excdo.dll        
   
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbQFE KBHotfixServer kbfix kbExchange2000preSP4fix kbbug KB891082 kbAudITPRO