FIX: You receive an error message, or other unexpected behavior when you access an NFS share after you apply hotfix 885930 (891078)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 2.3 OEM Only
  • Microsoft Windows Services for UNIX 3.0
  • Microsoft Windows Services for UNIX 3.5

SYMPTOMS

You may try to copy files to a Network File System (NFS) share or try to see the file list that is on an NFS share from a UNIX or Linux client. When you do this, you may experience one of the following symptoms, even though the owner of the files is root and is mapped to the NFS share:
  • You receive a "permission denied" error message.
  • You receive a "Stop 1E" system error message, and the system stops.
  • The contents of incorrect files are returned by the NFS server.

CAUSE

This problem occurs because you installed the following hotfix for Microsoft Windows Services for UNIX 2.3:

885930 FIX: Network File System (NFS) client users that do not have the "List Folder / Read Data" permission can still see the file list from an NFS share

Hotfix 885930 causes Server for NFS to close a file handle too soon when it handles a request from a client to list the contents of a directory. On later requests to access the file, such as to read the file or to obtain the attributes of the file, Server for NFS will try to use the file handle that it already closed. This behavior can cause a variety of symptoms. These include the symptoms that are described in the "Symptoms" section.

RESOLUTION

Windows Services for UNIX 2.3

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix 885930.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name   
   --------------------------------------------------------
   14-Dec-2004  19:26  5.3000.2117.18   78,336 Clilocks.dll 
   14-Dec-2004  19:26  5.3000.2117.18   31,744 Clusnfs.exe 
   14-Dec-2004  19:26  5.3000.2117.18   22,528 Dsctrs.dll 
   14-Dec-2004  19:26  5.3000.2117.18   24,064 Nfsonly.exe 
   14-Dec-2004  19:26  5.3000.2117.18   66,048 Nfssh.dll 
   14-Dec-2004  19:26  5.3000.2117.18   94,208 Nfsshare.exe 
   14-Dec-2004  19:26  5.3000.2117.18  143,360 Nfsshex.dll 
   14-Dec-2004  19:26  5.3000.2117.18  113,664 Nfssprop.dll 
   14-Dec-2004  19:26  5.3000.2117.18   94,720 Nfssvc.exe 
   14-Dec-2004  19:26  5.3000.2117.18  325,312 Nfssvr.sys
   14-Dec-2004  19:26  5.3000.2117.18   40,832 Portmap.sys
   14-Dec-2001  20:01  5.0.2134.1       35,600 Regini.exe 
   14-Dec-2004  19:26  5.3000.2117.18   72,800 Rpcxdr.sys
   10-Apr-2003  20:44                   27,102 Supphelp.chm
   14-Dec-2004  19:26  5.3000.2117.18   48,128 Upnfs3.exe

Windows Services for UNIX versions 3.0 and 3.5

Hotfix information

To resolve this problem on Microsoft Windows Services for UNIX versions 3.0 and 3.5, apply the hotfix that is described in the following Microsoft Knowledge Base article:

892561 FIX: The computer may stop responding when Server for Network File System (NFS) is serving multiple requests at the same time in Windows Services for UNIX 2.3 and later versions

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   25-Jan-2005  10:31  8.0.1969.26  326,848  Nfssvr.sys

WORKAROUND

To temporarily work around this problem, restart Server for NFS.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For additional information about Windows Services for UNIX, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbfix kbBug kberrmsg kbUNIXService kbQFE kbHotfixServer KB891078 kbAudITPRO