A Windows XP-based or Windows 2000-based DHCP client does not update the subnet mask when the DHCP server sends a new subnet mask (890946)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

A Microsoft Windows XP-based or Microsoft Windows 2000-based Dynamic Host Configuration Protocol (DHCP) client does not update the subnet mask when the DHCP server sends a new subnet mask. For example, when you change the subnet mask for the DHCP scope on a DHCP server, the client does not update the new subnet mask information when the client receives the new information from the DHCP server.

Note This problem does not occur when a DHCP server sends a new IP address that includes a new subnet mask to the DHCP client.

CAUSE

The subnet mask update is ignored by a Windows XP-based or Windows 2000-based DHCP client.

RESOLUTION

Windows XP hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-bit versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Jan-2005  00:58  5.1.2600.2601     111,104  Dhcpcsvc.dll     

Windows XP Professional, 64-bit edition (Itanium)

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Jan-2005  00:59  5.1.2600.1620     322,048  Dhcpcsvc.dll     IA-64
   26-Jan-2005  01:02  5.1.2600.1620     105,984  Wdhcpcsvc.dll    x86

Windows 2000 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Windows 2000 Service Pack 3

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Jan-2005  07:53  5.0.2195.7021      89,360  Dhcpcsvc.dll     
   

WORKAROUND

To work around this problem, perform a manual release and renew of the IP address lease. To do this, type the following commands at a command prompt. Press ENTER after each command.

ipconfig /release

ipconfig /renew

Alternatively, you can include the Ipconfig /release and Ipconfig /renew commands in a script that will run one time when a new user logs on.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

284193 How to run a logon script one time when a new user logs on

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPpreSP3fix kbWinXPsp3fix kbBug kbfix kbWin2000preSP5fix KB890946 kbAudITPRO