A memory leak occurs when you repeatedly open and close the Microsoft Exchange Information Store service performance counters on a remote computer (890459)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

Consider the following scenario. Microsoft Exchange 2000 Server is installed on a Microsoft Windows 2000-based computer. Additionally, you use a Microsoft Windows XP-based computer or a Windows 2000-based computer to remotely monitor the Microsoft Exchange Information Store service performance counters on the Exchange server. When you repeatedly open and close the Microsoft Exchange Information Store service performance counters on the remote computer, a memory leak occurs.

If you use the Performance Monitor tool (Perfmon.msc) to view the Handle Count counter for the Remote Registry service (Regsvc.exe) on the Exchange server, you may find that the Handle Count counter continues to increase.

Note You can use either the Performance Monitor tool or a user-created application to remotely monitor the Microsoft Exchange Information Store service performance counters. However, this problem occurs more frequently if you use a user-created application to monitor the Microsoft Exchange Store service performance counters.

CAUSE

This problem occurs if the Mdbperf.dll component leaks handles in the Remote Registry service. When the Mdbperf.dll component leaks handles in the Remote Registry service, a memory leak occurs.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size     File name
   --------------------------------------------------------
   28-Jan-2005   18:57   6.0.6617.41   49,152   Mdbperf.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbexchSTORE kbQFE kbfix kbExchange2000preSP4fix kbbug kbpubtypekc KB890459 kbAudITPRO