Presence information does not appear correctly in a Real-time Communications Client program when you connect to Office Live Communications Server 2005 over a dial-up connection (890301)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Standard Edition
  • Microsoft Office Live Communications Server 2005 Enterprise Edition

SYMPTOMS

If you create a program that uses the Microsoft Real-time Communications (RTC) Client API to connect to Microsoft Office Live Communications Server 2005, you experience the following symptoms:
  • The client program connects to Live Communications Server 2005 successfully, and user registration is successful.
  • Presence information for the connected user's contacts does not appear correctly. In this scenario, the connected user's contacts appear with a status of Offline.
  • BUDDY SUBSCRIBE events return a failed status code of 0x80EE000C.

    Note This error code means "SIP Transaction timed out."

CAUSE

This issue occurs if all the following conditions are true:
  • The RTC Client program connects to Live Communications Server 2005 by using a dial-up connection or by using a connection that has 56 kilobytes (KB) or less bandwidth.
  • The RTC Client program connects to Live Communications Server 2005 by using a TCP connection.
  • The RTC Client program has more than 150 entries configured in a contact list.
The RTC API version 1.3 does not support more than 150 contact entries in this scenario. In this scenario, the presence information for 150 contacts (buddies) over a 56 KB connection takes more than 32 seconds to download by using TCP. In this scenario, the RTC client program fails with a timeout error.

WORKAROUND

To work around this issue, use one of the following methods.

Method 1: Use Transport Layer Security

To work around this issue, configure the RTC client program to use a Transport Layer Security (TLS) connection together with compression. This enables the presence information to be downloaded before the RTC Client program times out.

Method 2: Reduce the number of contacts to 150 or less

In Live Communications Server 2005, specify the maximum number of contacts that a user may add. To do this, follow these steps:
  1. Start Live Communications Server 2005. To do this, click Start, point to Administrative Tools, and then click Live Communications Server 2005.
  2. Expand your forest, expand Domains, expand your domain, and then expand Live Communications servers and pools.
  3. Right-click your server or your pool, and then click Properties.
  4. On the General tab, type 150 in the Maximum contacts per user box.

    Important If your users are running Microsoft Windows Messenger 5.1 or earlier, you must specify the default limit of 150 contacts per user. Windows Messenger does not function correctly with more than 150 contacts per user.
  5. Click Apply, and then click OK.

MORE INFORMATION

For additional information about the RTC Client, visit the following Microsoft Web site: For additional information about how to obtain the RTC Client API, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:12/1/2004
Keywords:kbprb kbtshoot KB890301 kbAudDeveloper