Automatic updates are not downloaded from a server that is running Software Update Services, and "404" error messages are logged in the IIS log files (890060)



The information in this article applies to:

  • Microsoft Software Update Services, version 1.0

SYMPTOMS

When a Microsoft Windows XP Service Pack 1 (SP1)-based client computer tries to download automatic updates from a computer that is running Microsoft Software Update Services, the automatic updates are not downloaded. The self-update operation on the client computer is not completed successfully. The log files in Microsoft Internet Information Services (IIS) contain error messages that are similar to the following:
Date Time 10.20.0.1 HEAD /selfupdate/AU/x86/W2K/mui/wuaueng_en.cab Date Time 80 - 10.20.1.6 Industry+Update+Control 404 0 2
Date Time 10.20.0.1 GET /selfupdate/AU/x86/W2K/mui/wuaueng_en.cab Date Time 80 - 10.20.1.6 Industry+Update+Control 404 0 64
The "404" error messages are logged for the Wuaueng_en.cab file.

CAUSE

This problem occurs if the client computer is running Windows Multilingual User Interface Pack (MUI), Microsoft Journal Viewer 1.5, and Multilingual User Interface (MUI) Package for Windows Journal Viewer 1.5. In this scenario, the client computer tries to download the Wuaueng_en.cab file from the server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Software Update Services 1.0 Service Pack 1 (SP1).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time    Size    File name
-------------------------------------------
23-Sep-2004  02:23   27,341  Wuauclt_en.cab
08-Oct-2004  20:19   20,834  Wuaucpl_en.cab
23-Sep-2004  02:23   43,260  Wuaueng_en.cab

To apply this hotfix, copy the files that are included in the hotfix to the following folders on the server:
  • %SUSdir%\Content\Selfupdate\Au\X86\Xp\Mui
  • %SUSdir%\Content\Selfupdate\Au\X86\Netserver\Mui
  • %SUSdir%\Content\Selfupdate\Au\X86\W2k\Mui

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE KB890060 kbAudITPRO