Nothing is printed when you send a print job to a network printer server from a computer that is running Windows 2000 or Windows Server 2003 (889074)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you send a print job to a network print server from a computer that is running Microsoft Windows 2000 or Microsoft Windows Server 2003, nothing is printed. Additionally, an error message that is similar to the following is logged in the System event log:
Event Type: Error
Event Source: Print
Event Category: None
Event ID: 61
Description: The document Document Name owned by User Name failed to print on printer Printer Name. Win32 error code returned by the print processor: 3003. A StartDocPrinter call was not issued.

CAUSE

This problem may occur when new print jobs try to acquire a port when the port is still being used.

Note You may not be able to determine which print queue, print device, or specific error to use to troubleshoot the problem. This issue occurs because the underlying component reports an error that is overwritten. Only the last error is reported. For example, you may receive the following Win32 error code:
ERROR_SPL_NO_STARTDOC (3003)
This error code means that a StartDocPrinter call was not issued. You receive this error code when the print spooler cannot send data to the port. The print job is marked as "error printing". In this case, the print spooler repeatedly tries to send the data until you cancel the job. The error that the port monitor component returns is overwritten when you cancel the print job.

RESOLUTION

Windows 2000

To resolve this problem, obtain Windows 2000 Update Rollup 1 for Service Pack 4. To obtain this update, visit the following Microsoft Web site:Note You must install Windows 2000 Service Pack 4 to deploy Windows 2000 Update Rollup 1 for Service Pack 4.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesWindows 2000 Service Pack 4 (SP4) must be installed to apply this hotfix.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Jun-2004  23:05  5.0.2195.6951      46,352  Basesrv.dll         
   14-Dec-2004  11:35  0.2.0.2           138,000  Faxui.dll        
   17-Jun-2004  23:05  5.0.2195.6945     231,184  Gdi32.dll        
   17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll     
   14-Dec-2004  11:35  5.0.2195.6997     257,296  Localspl.dll     
   24-Mar-2004  02:17  5.0.2195.6898      37,136  Mf3216.dll       
   24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll          
   17-Jun-2004  23:05  5.0.2195.6928     335,120  Msgina.dll       
   24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
   02-Dec-2004  14:27  5.0.2195.7004   6,272,512  Sp3res.dll       
   14-Dec-2004  11:35  5.0.2195.6938      80,144  Spoolss.dll      
   24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll       
   05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll      
   10-Aug-2004  03:51  5.0.2195.6966   1,632,624  Win32k.sys
   19-Jun-2003  20:05  5.0.2195.6681      97,040  Win32spl.dll     
   17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll       
   17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll     
   10-Aug-2004  03:51  5.0.2195.6966   1,632,624  Win32k.sys
   17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll       

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Nov-2004  06:07  5.2.3790.237      860,160  Localspl.dll     IA-64
   30-Nov-2004  06:07  5.2.3790.220      234,496  Spoolss.dll      IA-64
     
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Nov-2004  22:17  5.2.3790.237      312,320  Localspl.dll     
   30-Nov-2004  22:17  5.2.3790.220       81,920  Spoolss.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Update Rollup 1 for Service Pack 4 and Windows Server 2003 Service Pack 1.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

824339 Improved reporting of Event ID 61 event messages to identify a print queue or a print device


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB889074 kbAudITPRO